Đề tài Chương trình hỗ trợ bán hàng

MỤC LỤC

MỞ ĐẦU .3

CHƯƠNG I. TÌM HIỂU MẠNG LAN VÀ NHU CẦU GHÉP NỐI 4

1.1. Giới thiệu về mạng máy tính. 4

1.2. Mạng cục bộ (LAN) 5

1.2.1. Chức năng của mạng LAN 5

1.2.2. Các kiểu mạng (Topology) 5

a. Mạng hình sao (Star Topology) 5

b. Mạng mạch vòng (Ring Topology) 7

c. Mạng tuyến tính (Bus Topology) 8

1.2.3. Đường truyền vật lý 9

a. Cáp đồng trục (Coaxial cable) 9

b. Cáp không có vỏ bọc chống nhiễu UTP (Unshielded TP) 10

c. Cáp có vỏ bọc chống nhiễu STP (Shielded Twisted Pair) 11

d. Cáp quang (Fiber optic cable) 11

1.2.4. Các phương pháp truy nhập đường truyền vật lý 11

a. CSMA/CD 12

b. Token 13

1.3. Các thiết bi mạng 16

1.3.1. Bộ giao tiếp mạng (NIC) 16

1.3.2. Bộ tiếp sức (Repeater) 16

1.3.3. Bộ tập chung tín hiệu (Hub) 17

1.3.4. Bộ chuyển mạch (Switch) 17

1.3.5. Bộ điều chế và giải điều chế (Modem) 18

1.3.6. Cầu nối (Bridge) 18

1.3.7. Bộ định tuyến (Router) 20

1.3.8. Cổng giao tiếp (Gateway) 20

1.4. Quản lý mạng bằng một số HĐH phổ biến. 20

a. Hệ điều hành UNIX 20

b. Hệ điều hành mạng Windows NT 21

c. Hệ điền hành mạng Windows For Workgroup 21

d. Hệ điều hành mạng Netware của Novell 21

1.5. Nhu cầu ghép nối Các mạng LAN 21

1.5.1. Mở đáu : 21

1.5.2. Giao diện nối kết 22

CHƯƠNG 2 . NGHIÊN CỨU VỀ GIAO THỨC TCP/IP 25

2.1. Mô hình tham chiếu OSI 25

2.1.1. Tầng vật lý (Physical) 26

2.1.2. Tầng liên kết dữ liệu (Data Link) 27

2.1.3. Tầng mạng (Network) 27

2.1.4. Tầng giao vận (Transport) 27

2.1.5. Tầng phiên (Session) 28

2.1.6. Tầng trình diễn (Presentation) 28

2.1.7. Tầng ứng dụng (Application) 29

2.2. Giao thức TCP/IP 30

2.2.1. So sánh mô hình OSI với TCP/IP 31

a. Lớp truy cập mạng ( Network access) 32

b. Lớp Internet ( NETWORK) 33

c. Lớp vận chuyển ( Transport ) 33

d. Lớp ứng dụng ( Application ) 33

2.2.2. Giao thức liên mạng IP 34

2.2.3. Giao thức điều khiển truyền TCP 37

2.2.4. Giao thức UDP. 39

2.2.5. Tóm tắt nguyên tắc hoạt động của TCP/IP: 43

 

doc120 trang | Chia sẻ: maiphuongdc | Ngày: 13/01/2014 | Lượt xem: 894 | Lượt tải: 0download
Bạn đang xem nội dung tài liệu Đề tài Chương trình hỗ trợ bán hàng, để tải tài liệu về máy bạn click vào nút DOWNLOAD ở trên
huộc tính còn lại là thuộc tính mô tả cho kiểu thực thể này. Chương III : Công nghệ Sử dụng MicroAccess là một trong các hệ quản trị cơ sở dữ liệu dễ dùng nhất trên thị trường để tạo các áp dụng cơ sở dữ liệu trên môi trường Windows. Phần mềm có nhiều công cụ trợ giúp rất tiện lợi để tạo các ứng dụng trong lĩnh vực quản lý. Do chạy trên môi trường Windows nên Access đã tận dụng được các thế mạnh của Windows như: Tính đa nhiệm, khả năng quản lý bộ nhớ lớn, tính độc lập thiết bị, khả năng xử lý các loại dữ liệu phi văn bản, khả năng tổ chức giao diện chương trình, sự thuận tiện trong việc tổ chức in ấn... Microsoft Access đã dự báo và đưa vào Access một số công cụ hữu hiệu và tiện lợi để tạo ra cơ sở dữ liệu rất mạnh, để tự động sản sinh chương trình cho hầu hết các bài toán thường gặp trong thực tế như trong quản lý, thống kê, kế toán. Với Access người dụng không phải viết từng câu lệnh cụ thể như trong Pasca, C hay Foxpro mà chỉ cần tổ chức dữ liệu và thiết kế các yêu cầu công việc cần giải quyết. I. Giới thiệu cơ sở dữ liệu (CSDL) của Access Một cơ sở dữ liệu là một tập hợp các thông tin liên quan tới một đối tượng cụ thể hoặc một theo một mục đích nào đó. Ví dụ như các thông tin về đặt hàng của khách hàng hoặc lưu trữ các thông tin sưu tầm về âm nhạc. Nếu cơ sở dữ liệu của bạn không được lưu trữ trên máy tính hoặc chỉ một phần của nó được lưu trữ, bạn có thể lưu trữ thông tin theo nhiều cách khác nhau nhưng để có thể lưu trữ được bạn phải tự tổ chức lấy một cách thức lưu trữ dữ liệu sao cho phù hợp nhất. Sử dụng Microsoft Access, bạn có thể quản lý tất cả các thông tin chỉ với một tệp tin cơ sở dữ liệu đơn lẻ. Trong tệp tin cơ sở dữ liệu này thông tin của bạn sẽ được lưu trữ trong các hộp chứa gọi là các bảng. Xem, thêm thông tin mới và cập nhật thông tin trên các bảng được thực hiện một cách trực tiếp trên các mẫu biểu (Forms). Tìm kiếm, lấy các thông tin được thực hiện nhờ các truy vấn (Query) và phân tích in ấn, trình bầy dữ liệu được thực hiện bằng cách tạo ra các báo biểu (Report). - Để lưu trữ thông tin, bạn cần tạo một bảng cho mỗi kiểu thông tin cần lưu trữ.Để thực hiện việc tổ hợp các thông tin trên nhiều bảng lại với nhau bạn cần định nghĩa quan hệ giữa các bảng. - Việc tìm kiếm thông tin và lấy các thông tin theo một đIều kiện cho trước mà bạn đã chỉ rõ, bao gồm các thông tin thuộc nhiều bảng khác nhau được thực hiện nhờ các truy vấn (Query). Một truy vấn có thể cũng thực hiện công việc cập nhật thông tin, xoá các bản ghi dữ liệu hoặc thực hiện các tính toán trên dữ liệu. - Để xem, nhập dữ liệu và thay đổi dữ liệu một cách trực tiếp trong một bảng cần tạo một mẫu biểu (Forms). Khi mở mẫu biểu, Microsoft Access sẽ lấy các dữ liệu trên một hoặc nhiều bảng và hiển thị chúng lên các mẫu biểu theo cách mà bạn đã chọn lúc thiết kế - Report được sử dụng để phân tích, trình bầy in ấn dữ liệu. Ví dụ: Bạn có thể thực hiện việc in một báo biểu trong đó trình bầy một nhóm dữ liệu và thực hiện các phép tính toán trên nhóm dữ liệu đó, hoặc với một Báo biểu khác dùng để in dữ liệu theo các định dạng khác nhau. Để làm việc với các đối tượng trong một cơ sở dữ liệu của Microsoft Access ta sử dụng cửa sổ cơ sở dữ liệu (Database Window ). Hình 5: Cửa sổ Database Window Trên cửa sổ này chứa các đối tượng của Microsoft Access bạn có thể thực hiện sửa chữa các đối tượng có sẵn hoặc tạo mới những đối tượng cần thiết cho cơ sở dữ liệu. II. Giới thiệu công cụ của Access Access đã cung cấp cho ta 6 đối tượng cơ bản là: Bảng(Table), Truy Vấn (Query), Mẫu Biểu (Form), Báo biểu (Report), Macro và Đơn Thể (Module). Sáu đối tượng này có những chức năng khác nhau nhưng chúng lại có mối quan hệ mật thiết với nhau, hỗ trợ lẫn nhau để xây dựng lên một hệ thống hoàn chỉnh, toàn vẹn. 1. Bảng (Table) Bảng là một tập hợp dữ liệu theo một chủ đề nào đó, ví dụ như : tập hợp các thông tin lưu trữ về sản phẩm, khách hàng. . . Sử dụng một bảng (Table) để lưu trữ thông tin cho từng chủ đề, điều này làm cho cơ sở dữ liệu của bạn trở lên hiệu quả hơn, giảm thiểu khả năng mắc lỗi. Bảng dữ liệu được tổ chức dưới dạng các cột (gọi là các trường Fields) và các dòng (gọi là các bản ghi Records). Các trường đều có cùng một kiểu dữ liệu mà nó lưu trữ Mỗi bản ghi trên một bảng chứa các đầy đủ thông tin hoàn chỉnh về một đối tượng. Dưới dạng một bảng tính, bạn có thể thêm, sửa hoặc xem dữ liệu trong bảng Bạn cũng có thể kiểm tra và in dữ liệu trong bảng dữ liệu của bạn,hoặc thực hiện việc lọc sắp xếp dữ liệu, thay đổi cách hiển thị dữ liệu, thay đổi cấu trúc bảng (thêm, xoá các cột (Fields) ...) Trong cửa sổ Database chọn Tabs Table và chọn NEW để tạo một bảng mới hoặc mục DESIGN để thiết kế sửa lại cấu trúc của một bảng đã tồn tại. * Các bước tạo một bảng dữ liệu : + Đưa vào tên một trường hoặc đổi tên một trường (nếu làm việc với các bảng đã có sẵn ) trong cột Field Name Tên trường, gồm một dãy không quá 64 ký tự bao gồm chữ cái, chữ số và cả khoảng trống. + Chọn kiểu dữ liệu tương ứng với trường đó trong cột Data Type Kiểu dữ liệu cho các trường có thể là các kiểu dữ liệu sau: Kiểu Mô tả Kích thước Text Ký tự Dài Ê 255 byte Memo Ký tự Dài Ê 64000 byte Number Số nguyên, thực Dài 1,2,4 hoặc 8 byte Date/Time Ngày, tháng, giờ Dài 8 byte Currency Tiền tệ Dài 8 byte Autonumber Số Dài 8 byte Yes/ No Boolean Dài 1 bit OLE object Đối tượng nhúng kết hình ảnh + Thiết lập các thuộc tính cho trường dữ liệu. Các thuộc tính cho mỗi trường phụ thuộc vào kiểu dữ liệu của trường đó. Các thuộc tính được bổ sung làm tăng hiệu quả khi làm việc trên các trường. + Chọn một khoá cho bảng dữ liệu.Bạn cần sử dụng một tên gọi duy nhất nhằm xác định một bản ghi trong bảng dữ liệu, tên gọi đó chính là khoá. Một khóa có thể là tổ hợp của nhiều trường trên bảng dữ liệu. Các khoá còn được sử dụng để kết nối giữa bản ghi của một bảng này với một bản ghi trên bản khác. Để đặt khoá cho bảng ta làm như sau: - Chọn tên trường muốn làm khoá - Kích chuột vào Primary Key trên thanh menu ToolBar hoặc kích vào biểu tượng chiếc chìa khóa trên dòng các biểu tượng. + Thiết lập quan hệ giữa các bảng Access dùng quan hệ để đảm bảo những ràng buộc toàn vẹn giữa các bảng liên quan trong phép thêm, sửa, xoá mẫu tin. Đặt quan hệ là chỉ định một trường này hay một nhóm trường chứa cùng một giá trị trong các mẫu tin có liên quan (thường đặt quan hệ giữa khoá chính của một bảng với một trường nào đó của bảng khác và các trường này có cùng tên cùng kiểu) * Các loại quan hệ - Mối quan hệ một - đối - một : đòi hỏi giá trị của trường khoá trong chỉ một bản ghi của bảng mới phải so khớp với giá trị tương ứng của trường có quan hệ trong bảng hiện có. Trong trường hợp này, trường khoá trong bảng mới phải là duy nhất - Mối quan hệ nhiều -đối - một : cho phép bảng mới có nhiều giá trị trường khoá tương ứng với chỉ một giá trị trong trường quan hệ của bảng hiện có. Trong trường hợp này, ta có thể có các giá trị trường khoá trùng lặp. Đây là kiểu phổ biến nhất. - Mối quan hệ một -đối - nhiều: đòi hỏi trường khoá chính của bảng mới phải là duy nhất, nhưng các giá trị trong trường khoá của bảng mới có thể so khớp với nhiều mục trong bảng quan trên hệ cơ sở dữ liệu hiện có. Trong trường hợp này,trường quan hệ trong bảng của cơ sở dữ liệu hiện có sẽ có một mối quan hệ nhiều -đối - một với trường khoá chính trong bảng mới. * Cách tạo quan hệ - Trong cửa sổ Database Window chọn Relationships từ menu Tools - Chọn các bảng ,các truy vấn để đưa vào quan hệ - Chọn 1 trường từ bảng chính ( Primary Table ) và kéo sang trường tương ứng của bảng quan hệ, rồi bấm chuột tại Create để tạo quan hệ. Chọn mục Enforce Referential Intergity. Nếu thoả mãn: + Trường của bảng chính là khoá chính + Các trường quan hệ có cùng kiểu dữ liệu + Cả hai bảng trong quan hệ cùng thuộc một CSDL thì Access luôn đảm bảo tính chất: Mỗi bản ghi trong bảng quan hệ phải có một bản ghi tương ứng trong bảng chính. Điều này ảnh hưởng đến các phép thêm và xoá trong bảng quan hệ. Tuỳ chọn Cascade Update và Cascade Delete - Khi đã đánh dấu Enforce Referential Intergity có thể sử dụng thêm các tuỳ chọn sau: + Cascade Update Ralated fields + Cascade Delete Ralated fields với ý nghĩa sau: - Cascade Update: Khi sửa giá trị trường khoá trong bảng chính thì giá trị tương ứng của bản ghi trong trường quan hệ cũng sẽ bị sửa theo. - Cascade Delete: Khi xoá một bản ghi trong bảng chính thì bản ghi tương ứng trong trường quan hệ cũng sẽ bị xoá theo. 2 . Mẫu Biểu ( FORMS ) Mẫu biểu (FORMS ) được sử dụng cho nhiều mục đích khác nhau: + Tạo ra một cách vào dữ liệu cho các bảng dữ liệu + Tạo ra một sự luân chuyển dữ liệu giữa các Mẫu biểu đã mở hoặc giữa các Mẫu biểu và Báo biểu + Tạo cho người sử dụng một hộp thoại để thực hiên nhập dữ liệu và đưa ra các hành động kiểm tra ứng với công việc nhập. Các dữ liệu thể hiện trên Mẫu biểu được lấy dưới dạng các bản ghi trong các bảng dữ liệu, hoặc thông tin thể hiện được tạo ra khi thiết kế Mẫu biểu (ví dụ như các dòng thông báo, các nhãn ..). Sự liên kết giữa một Mẫu biểu và các bản ghi dữ liệu trong một Bảng bằng cách sử dụng các đối tượng gọi là các điều khiển. Kiểu điều khiển hay được dùng để hiển thị và nhập dữ liệu là một hộp văn bản (Text Box ). Các quá trình thiết kế một Mẫu biểu. Đưa vào Mẫu biểu các điều khiển. Access cung cấp các loại điều khiển sau: + Các hộp văn bản ( text box ) + Các hộp điều khiển Combo (Combo box) + Các hộp liệt kê (List box) + Các điều khiển nhãn (Label) + Nhóm lựa chọn (Option Group), + Hình ảnh (Object Frame) + Hộp kiểm tra (Check Box) + Nút bật tắt (Toggle Button) + Nút lựa chọn (Option Button ) . . . . . . . . .. . . + Thực hiện chỉnh sửa các điều khiển nhằm tạo một Mẫu biểu theo ý muốn. Các thao tác có thể làm như: - Dịch chuyển, thay đổi kích cỡ canh lề các điều khiển - Thay đổi các nhãn hoặc các điều khiển - Buộc các điều khiển vào các trường dữ liệu trên bảng nguồn - Thay đổi các dạng điều khiển cho phù hợp theo yêu cầu Để tăng cường tính hiệu quả của một Mẫu biểu ta có thể đưa thêm vào một phần hoặc nhiều phần của Mẫu biểu. Hầu hết các Mẫu biểu đều có phần mô tả chi tiết (Detail), nhưng Mẫu biểu cũng có thể bao gồm cả các phần: phần đầu Mẫu biểu (Forms Header), phần đầu trang (Page Header), phần cuối trang (Page Footer), phần cuối mẫu biểu (Forms Footer). +Liên kết dữ liệu trong các bảng vào các Mẫu biểu * Để có thể thực hiện công việc cập nhật, tìm kiếm, thể hiện dữ liệu nằm trên trên nhiều Bảng, cần tạo ra các Mẫu biểu con (Sub Forms), các Mẫu biểu con được nhúng và trong các Mẫu biểu chính. Mẫu biểu chính thể hiện các thông tin truy vấn trên bảng chính, còn Mẫu biểu con thể hiện các thông tin trên các bảng có liên quan trong truy vấn đang xét trên Mẫu biểu chính. 3. Truy Vấn ( Query ) Truy vấn là công cụ mạnh của Access dùng để tổ hợp, sắp xếp, tìm kiếm dữ liệu trên các bảng dữ liệu. Khi thực hiện truy vấn sẽ nhận được một tập hợp kết quả thể hiện trện màn hình dưới dạng bảng. Sử dụng truy vấn để xem, thay đổi và phân tích dữ liệu theo nhiều kiểu khác nhau. Truy vấn cũng là các bảng dữ liệu nguồn cho các Mẫu biểu, Báo biểu. Sử dụng truy vấn để thực hiện các tính toán trên các bảng dữ liệu như: Tính tổng, đếm, tính giá trị lớn nhất, nhỏ nhất ... hoặc chỉ thực hiện tính toán trên một nhóm dữ liệu đã chỉ ra trong tiêu chuẩn tìm kiếm. Loại truy vấn thường hay được sử dụng nhất là Select Query (Truy vấn chọn). Với truy vấn chọn có thể thực hiện lấy dữ liệu trên một hay nhiều bảng thỏa mãn các tiêu chuẩn đã được chỉ rõ khi xây dựng truy vấn và trình bầy dữ liệu theo cách thức mà bạn muốn. * Ngoài truy vấn Select Query ra còn có các truy vấn khác là: + Crosstab Query: Thể hiện dữ liệu hàng cột. + Action Query: Tạo bảng mới, thêm, sửa và xoá các mẫu tin trong bảng. + Like Query: Tìm kiếm theo mẫu. + Union Query: Các thông tin được tổ hợp trong nhiều truy vấn khác nhau. Một Union Query được tạo nên bằng cách hợp các truy vấn + Data Definition Query: Truy vấn được xây dựng từ câu lệnh SQL, dùng để tạo mới hoặc thay đổi cấu trúc của 1 bảng. a. Cách tạo truy vấn Các bước tạo mới một truy vấn (Select Query): + Vào cửa sổ Database Window chọn mục Query, New. + Chọn Design View để thực hiện thiết kế một truy vấn mới + Chọn các bảng/truy vấn làm nguồn dữ liệu để xây dựng truy vấn mới. Cửa sổ tạo Select Query có hai phần * Phần trên hiện các bảng/truy vấn nguồn. * Phần dưới được gọi là QBE (Query By Example) chứa các trường truy vấn mới cần xây dựng + Chọn các trường đưa vào truy vấn hoặc loại bỏ các trường khỏi truy vấn + Đưa vào các công thức tính toán trên dữ liệu truy vấn. Các hàm như: SUM (tổng), AVG (trung bình), MIN (giá trị nhỏ nhất), MAX (giá trị lớn nhất), COUNT (đếm), FIRST (giá trị đầu tiên), LAST (giá trị cuối cùng). + Định thứ tự sắp xếp để cho bảng kết quả + Lập tiêu chuẩn lựa chọn (điều kiện tìm kiếm) để hiện những thông tin cần quan tâm trong bảng kết quả. Truy vấn chỉ thể hiện các dữ liệu đã chỉ ra trong truy vấn nếu dữ liệu của trường đó thỏa mãn điều kiện đã chỉ ra. Có thể đưa vào nhiều các tiêu chuẩn tìm kiếm bằng cách sử dụng các phép toán AND, OR + Đưa vào các tính chất cho các trường dữ liệu sẽ được hiển thị trong bảng truy vấn Ví dụ: Muốn hiển thị các mẫu tin không trùng lặp nhau theo 1 trường nào đó của 1 truy vấn ta sử dụng thuộc tính Unique Values của truy vấn và đặt giá trị Yes cho thuộc tính này b. Một số truy vấn khác: Truy vấn thông số (Parameter Query) Giá trị trong biểu thức điều kiện không cần định trước mà sẽ được nhập vào mỗi khi truy vấn thực hiện Trong biểu thức điều kiện, thay cho một giá trị cụ thể ta đưa vào một thông báo trong 2 dấu []. Một thông báo như vậy được gọi là một thông số. Dòng thông báo này sẽ xuất hiện như một chỉ dẫn nhập dữ liệu khi thực hiện một truy vấn Truy vấn Crosstab Truy vấn Crosstab được dùng để tóm lược dữ liệu và trình bày kết quả theo dạng cô đọng như một bảng tính. Vì vậy nó được dùng để tạo nên số liệu so sánh và dự đoán hướng phát triển của dữ liệu Cách tạo truy vấn Crosstab: + Chọn các bảng/truy vấn nguồn + Chọn mục Crosstab Query trong menu Query. Kết quả trong QBE xuất hiện thêm hai hàng là Total và Crosstab + Đưa vào các trường với mục đích: - Dùng làm tiêu chuẩn lựa chọn các bản ghi: Total, Where Crosstab: (để trống) Criteria: điều kiện - Phân nhóm và hiển thị theo hàng: Total: Group By Crosstab: Row Heading Sort: (có thể dùng) Criteria: (có thể dùng) - Tính theo nhóm và hiển thị theo hàng: Total: Hàm Sum, Avg, Count,... Crosstab: Row Heading Sort: (có thể dùng) Criteria: (có thể dùng) - Một trường dùng để phân nhóm con và hiển thị theo cột: Total: Group By Crosstab: Column Heading - Một trường dùng để tính toán trên các nhóm và hiển thị kết quả theo bảng: Total: Hàm Sum, Avg, Count,... Crosstab: Value Chú ý: Có thể dùng biểu thức điều kiện chứa thông số Truy vấn dùng câu lệnh SQL Bản chất của các truy vấn là các câu lệnh SQ L, một mặt Access hỗ trợ cho ta chương trình Query Builder, tự sản sinh các câu lệnh SQL, mặt khác Access cũng cung cấp phần đề cho người sử dụng đưa vào các câu lệnh SQL không phải do chương trình Query Builder sản sinh. Các lệnh SQL gồm: SELECT ( truy vấn thông tin ) CREATE_TABLE (tạo một bảng mới ) ALTER TABLE (thay đổi cấu trúc của bảng dữ liệu) DROP TABLE (xoá bảng ) CREATE INDEX (xây dựng chỉ mục trên bảng dữ liệu) DROP INDEX (xoá chỉ mục trên bảng dữ liệu) . . . . . . Truy vấn Action Truy vấn Action dùng để: + Tạo bảng dữ liệu mới (Maketable). Kết quả truy vấn được ghi ra đĩa dưới dạng một bảng mới + Bổ sung vào cuối một bảng đã có (Append Query). Kết quả truy vấn được bổ sung vào bảng + Xoá các mẫu tin từ 1 hay nhiều bảng (Delete Query) + Chỉnh sửa dữ liệu trong một nhiều bảng (Update Query) * Cách tạo: Truy vấn tạo bảng - Tiến hành thiết kế như đối với một truy vấn thông thường - Sau đó chọn menu Query, MakeTable thì Access sẽ yêu cầu đặt tên cho bảng cần tạo trong trường hợp sau: - Đặt tên cho bảng và trở về thiết kế truy vấn - Ghi thiết kế và đặt tên cho truy vấn - Thực hiện truy vấn mới để nhận bảng mới Truy vấn bổ sung (Append Query) - Thiết kế như đối với một truy vấn thông thường - Sau đó chọn menu Query. Access yêu cầu nhập tên bảng cần bổ sung dữ liệu (bảng đó phải tồn tại) - Nhập tên bảng cần bổ sung dữ liệu - Trong hàng Field ta đưa vào các trường của bảng/truy vấn nguồn - Trong hàng Append To ta đưa vào các trường tương ứng của bảng cần bổ sung dữ liệu Truy vấn xoá (Delete Query) - Chọn bảng/truy vấn nguồn - Chọn menu Query, Delete. Kết quả xuất hiện thêm hàng Delete trong QBE - Kéo dấu * của bảng (nguồn) muốn xoá vào một ô trong hàng Field. Khi đó trên dòng Delete xuất hiện từ From của ô tương ứng - Kéo các trường dùng để lập điều kiện vào dòng Field. Khi ấy từ Where xuất hiện trên dòng Delete - Ghi thiết kế và đặt tên truy vấn - Thực hiện truy vấn Truy vấn sửa (Update Query) - Chọn các bảng/truy vấn nguồn - Chọn menu Query, Update. Kết quả hiện thêm hàng Update To trong phần QBE - Kéo các trường cần sửa và các trường dùng để lập điều kiện vào hàng Field (cùng 1 trường có thể vừa là trường cần sửa, vừa là trường cần điều kiện) - Đặt các biểu thức cần thiết vào Update To của các trường cần sửa. Trong biểu thức này có thể dùng các trường của bảng/truy vấn nguồn, các hàm chuẩn của Access và các hàm tự lập - Đặt điều kiện vào ô Criteria của các trường điều kiện - Ghi thiết kế và đặt tên truy vấn - Thực hiện truy vấn 4. Báo biểu (Report) Báo biểu là công cụ thuận tiện tuyệt vời để tổ chức công việc in dữ liệu của các bảng dữ liệu hay các truy vấn. Nguồn dữ liệu cho các báo biểu được lấy từ các bảng đữ liệu ,các truy vấn, các câu lệnh SQL. Báo biểu cho phép thực hiện các chức nắng sau : + Sắp xếp dữ liệu trước khi in và in theo từng nhóm + Sắp xếp và phân nhóm dữ liệu tới 10 cấp. Cho phép thực hiện các phép toán để nhận dữ liệu tổng hợp trên mỗi nhóm như: SUM (tổng), AVG (trung bình cộng), COUNT (đếm), MAX, MIN,... Ngoài ra dữ liệu tổng hợp nhận được trên các nhóm để có thể đưa vào công thức để nhận được sự so sánh, đối chiếu trên các nhóm và trên toàn báo cáo. + In dữ liệu của nhiều bảng có quan hệ trên 1 báo cáo (dùng báo biểu con Sub Report). + Việc chọn Font chữ, cỡ chữ, kiểu in và việc trình bày trên báo biểu được tiến hành rất đơn giản và nhanh chóng Để tăng tính hiệu quả của báo biểu ta có thể đưa thêm vào các phần sau vào trong báo biểu: + Đầu báo biểu (Report Header) + Đầu trang (Page Header) + Thân báo biểu (Report Detail) + Cuối trang (Page Footer) + Cuối báo biểu (Report Footer) * Báo biểu có 3 chế độ hiển thị - Design View: Dạng thiết kế báo biểu, dùng để tạo 1 báo biểu mới hoặc chỉnh sửa lại 1 báo biểu đã có. - Sample Preview: Xem thử kết quả báo biểu, kiểm tra cách sắp đặt các điều khiển, Form và cỡ chữ (chỉ thể hiện ra một phần báo biểu để làm mẫu). - Print Preview: Xem và kiểm tra toàn bộ nội dung trước khi đưa ra máy in. a. Các bước xây dựng báo biểu Trong cửa sổ Database Window chọn Report, New thì được cửa sổ để thiết kế xây dựng Báo biểu (Report). Chọn một bảng/truy vấn nguồn (nếu cần sử dụng) Xử dụng hộp công cụ để tạo các điều khiển trên báo biểu. Khi thiết kế xong tiến hành ghi và đặt tên cho báo biểu. b. Các điều khiển thường sử dụng để xây dựng báo biểu Điều khiển Line, Rectangle để kẻ đường thẳng và các ô hình chữ nhật. Điều khiển TextBox Sử dụng điều khiển Page Break trên hộp cộng cụ để thực hiện ngắt trang. Để in số trang, dùng hộp văn bản kiểu tính toán (trong đó ghi công thức =Page). Hộp này có thể đặt ở đầu trang hoặc cuối trang.của báo biểu. c. In báo biểu Để in kết quả của báo biểu thì: + Chọn báo biểu cần in từ cửa sổ Database + Chọn chức năng Print từ menu Edit Để in các thông tin về cấu trúc của báo biểu thì dùng chức năng Print Definition trong menu File. d. Sắp xếp và tập hợp dữ liệu theo nhóm * Sắp xếp dữ liệu Khả năng sắp xếp: + Có thể sắp xếp theo trường + Có thể sắp theo 1 biểu thức có chứa các trường + Có thể sẵp xếp tối đa trên 10 trường hoặc biểu thức Thao tác: + Mở báo biểu trong chế độ Design View. + Chọn mục Sorting and Grouping từ menu View khi ấy hiện cửa sổ + Đưa các trường vào biểu thức dùng để sắp xếp vào cột Field Expression.(mỗi trường hoặc biểu thức đặt trên một dòng) + Chọn thứ tự sắp xếp trong cột Sort Order (nếu sắp xếp theo nhiều trường hoặc biểu thức thì thứ tự ưu tiên từ trên xuống dưới). * Phân nhóm dữ liệu Có thể phân nhóm bất kỳ trường hay biểu thức nào đã được đưa vào cột Field Expression Thứ tự phân nhóm: Giả sử ta phân nhóm theo 3 trường, với số thứ tự từ trên xuống dưới thì dữ liệu được phân nhóm như sau: + Trước hết các bản ghi được phân nhóm theo Field1. Ta được nhóm cấp 1 + Trong mỗi nhóm cấp 1, các bản ghi lại được phân nhóm theo Field2. Ta được các nhóm cấp 2. + Trong nhóm cấp 2, các bản ghi lại được phân nhóm theo Field3. Ta được các nhóm cấp 3 Các nhóm dữ liệu theo trường phân nhóm: Được quy định bằng các thuộc tính Group On và Group Interval của trường phân nhóm trong cửa sổ Sorting và Grouping * Nhóm đầu và nhóm cuối Tạo đầu nhóm và cuối nhóm trên báo biểu + Mở cửa sổ Sorting và Grouping + Chọn trường hoặc biểu thức phân nhóm + Đặt thuộc tính của (trường phân nhóm) Group Header là Yes để thêm phần đầu nhóm, hoặc No để huỷ phần đầu nhóm. + Đặt thuộc tính Group Footer là Yes để thêm phần cuối nhóm, là No để huỷ Trên phần đầu nhóm và cuối nhóm có thể đạt bất kỳ điều khiển nào của báo biểu. Tại phần đầu nhóm và cuối nhóm, có thể sử dụng một số hàm chuẩn của Access để tổng hợp dữ liệu của mỗi nhóm. * In theo nhóm Thuộc tính Keep Together trong cửa sổ Sorting And Grouping cho 2 khả năng in dữ liệu nhóm như sau: - Nếu Keep Together: Whole Group thì nhóm sẽ bắt đầu in từ trang mới, nếu phần còn lại của trang không chứa hết tất cả các bản ghi của nhóm. - Nếu Keep Together: With First Detail thì trên mỗi trang tiêu đề nhóm sẽ được in kèm với ít nhất 1 bản ghi. e. Nhóm dữ liệu theo trường phân nhóm * Đối với trường/biểu thức số Dùng thuộc tính Group On - Phân nhóm theo giá trị ta đặt: Group On: Each Value - Phân nhóm theo miền giá trị đặt: Group On: Interval và thuộc tính Group Interval là 1 giá trị số. Khi đó miền phân nhóm là các đoạn có độ dài bằng giá trị đưa vào thuộc tính Group Interval và mốc là 0. * Đối với trường/biểu thức Date/Time Dùng thuộc tính Group On - Phân nhóm theo giá trị ta đặt: Group On: Each Value - Phân nhóm theo miền giá trị: Miền giá trị tính theo một trong các đơn vị: Year (năm), Qtr (qúi), Month (tháng), Week (tuần), Day (ngày), Hour (giờ), ... Để phân nhóm theo miền giá trị ta đặt: - Thuộc tính Group On là một trong các giá trị trên. - Thuộc tính Group Interval là một giá trị số. * Đối với trường/biểu thức Text Dùng thuộc tính Group On - Phân nhóm theo giá trị ta đặt: Group On: Each Value - Phân nhóm theo các ký tự đầu tiên: + Trên dòng thuộc tính Group On ta đặt Prefix Character. + Trên dòng thuộc tính Group Interval đặt 1 giá trị nguyên n. Khi đó các bản ghi trùng nhau trên n ký tự đầu tiên của trường/biểu thức phân được đưa vào 1 nhóm. g. Tổng hợp dữ liệu trên báo biểu * Tổng hợp dữ liệu trên các nhóm - Tạo các điều khiển Unbound vào đầu nhóm hoặc cuối nhóm. - Đặt một trong các hàm chuẩn của Access vào các ô điều khiển. * Tổng hợp dữ liệu trên toàn báo biểu Cũng làm như trên, nhưng các điều khiển được đặt ở đầu biểu hoặc cuối biểu * So sánh dữ liệu tổng hợp trên các phần của báo biểu - Tạo các ô điều khiển tại đầu hoặc cuối mỗi phần để nhận dữ liệu tổng hợp trên các phần. Đặt tên cho ô điều khiển. - Xử dụng các ô điều khiển nói trên để thực hiện các phép so sánh dữ liệu tổng hợp trên các phần khác nhau của báo biểu. h. Báo biểu chính và báo biểu phụ Cách tổ chức báo biểu chính và báo biểu phụ hoàn toàn giống như việc tổ chức Mẫu biểu chính và Mẫu biểu phụ ở trong phần giới thiệu Mẫu biểu 5. Macro Macro bao gồm 1 dãy các hành động Action là 1 đoạn chương trình dùng để tự động hoá các thao tác và tổ chức giao diện chương trình. Dùng Macro để mở các đối tượng như bảng, truy vấn, mẫu biểu, báo biểu. Ví dụ: Bạn có thể chạy một Macro để in một Báo biểu khi người sử dụng nhấn chuột vào một nút lệnh. Một Macro có thể là một Macro được tạo nên bởi một chuỗi các hành động hoặc có thể nó là một nhóm các Macro. Bạn có thể sử dụng một biểu thức điều kiện để xác định xem trong các trường hợp thì hành động nào được chạy. Nhóm các Macro có thể giúp bạn quản lý cơ sở dữ liệu của bạn một cách dễ dàng hơn a. Cách tạo Macro Chọn mục Macro trong cửa sổ Database Window, hoặc menu View. Sau đó chọn New Trong cột hành động (Action ) hãy chọn một hành động trong danh sách hành động mà bạn muốn sử dụng. Chỉ rõ các đối cho hành động nếu hành động đòi hỏi cần có các đối. b. Thực hiện Macro Bạn có thể thực hiện các Macro một cách trực tiếp, từ các Macro khác, hoặc từ trong một thủ tục xử lý một sự kiện, hoặc để đáp ứng các sự kiện xảy ra trên các Mẫu biểu, Báo biểu hoặc trên các điều khiển. Ví dụ: Bạn có thể gắn một Macro v

Các file đính kèm theo tài liệu này:

  • doc27185.DOC