Đề tài Làm việc với sơ đồ mạch nguyên lý (Schematic)

 

v Giới thiệu về DXP 1

v Làm việc với DXP 2

v Làm việc với sơ đồ mạch nguyên lý (Schematic) 3

v Làm việc với sơ đồ mạch in (PCB) 7

ỉ Để nâng cao tính chuyên nghiệp khi vẽ mạch ta có thể thêm vào các phần sau. 13

 

doc16 trang | Chia sẻ: huong.duong | Ngày: 14/09/2015 | Lượt xem: 1551 | Lượt tải: 1download
Bạn đang xem nội dung tài liệu Đề tài Làm việc với sơ đồ mạch nguyên lý (Schematic), để tải tài liệu về máy bạn click vào nút DOWNLOAD ở trên
PROTEL DXP 2004 Giới thiệu về DXP DXP (Design Explorer - Trình duyệt thiết kế) là một hệ thống thiết kế mạch điện tử hoàn thiện 32 bit trên nền Windows 2000 và Windows XP. Nó là một môi trường phát triển tích hợp, cung cấp một loạt các công cụ thiết kế mạnh. Khi tạo ra các trang văn bản thiết kế, bạn có thể dễ dàng chuyển đổi giữa các trình soạn thảo, ví dụ giữa các trình soạn thảo sơ đồ mạch nguyên lý (Schematic) và trình soạn thảo mạch in (PCB). Trình duyệt sẽ thay đổi các thanh công cụ và các menu tùy theo trình soạn thảo mà bạn đang làm việc. Tên của các panel được hiển thị ở góc dưới bên phải không gian làm việc. Bạn có thể click vào tên của các panel để mở chúng và có thể di chuyển các panel để tạo giao diện làm việc theo ý muốn. DXP lưu giữ tất cả các trang văn bản thiết kế và các file kết quả trên đĩa cứng dưới dạng các file riêng biệt. Bạn có thể sử dụng trình duyệt để tìm chúng. Các file đề án được tạo ra để chứa các liên kết đến các trang văn bản thiết kế. Làm việc với DXP Tạo ra một đề án mới Một đề án trong DXP chứa các liên kết đến tất cả các văn bản thiết kế và các cài đặt có liên quan. Một file đề án có phần mở rộng là .PriPCB, là một file văn bản liệt kê các trang văn bản thiết kế có trong đề án và các cài đặt có liên quan được sử dụng. Các trang văn bản không được kết hợp vào một đề án được gọi là văn bản tự do (Free Document). Mỗt khi đề án được biên dịch thì quá trình kiểm tra lại so sành và đồng bộ hóa được thực hiện. Bất kỳ sự thay đổi nào đối với các trang văn bản cũng được cập nhật vào đề án khi biên dịch. Quá trình tạo ra một đề án mới là giống nhau cho tất cả các loại đề án. Tạo ra một đề án PCB mới Một đề án PCB được sử dụng trong thiết kế mạch in. Thực hiện các bước sau để tạo ra một đề án PCB mới: Chọn File > New > PCB Project từ menu. Panel Project hiển thị . Một file đề án mới PCB project1.PrjPCB xuất hiện mà chưa có văn bản nào thêm vào. Thay tên của file đề án mới với phần mở rộng là .PrjPCB bằng các chọn File > Save Project as. Chọn đường dẫn đến vị trí trên đĩa cứng mà bạn muốn lưu đề án và nhập tên trong trường File Name và chọn Save. Làm việc với sơ đồ mạch nguyên lý (Schematic) Tạo ra một trang sơ đồ mạch nguyên lý (Schematic) mới. Chọn File > New > Schematic từ menu. Một trang sơ đồ mạch còn trống có tên là Sheet1.SchDoc hiển thị trong cửa sổ thiết kế và tự thêm và đề án. Tên trang sơ đồ được liệt kê trong mục Source Document ngay dưới tên đề án trong tab Projects. Đổi tên file sơ đồ mới với phần mở rộng là “.SchDoc “ bằng cách chọn File > Save as. Xác định vị trí trên đĩa cứng mà bạn muốn lưu file sơ đồ, nhập tên file trong trường File Name và chọn Save. Khi trang sơ đồ mạch mở ra, ta sẽ thấy rằng không gian làm việc thay đổi. Thanh công cụ chính gồm có các nút lệnh mới, các thanh công cụ mới xuất hiện và trên menu xuất hiện các mục mới. Điều đó cho thấy bạn đang làm việc trong trình soạn thảo sơ đồ mạch nguyên lý (Schematic). Cài đặt các lựa chọn cho trang sơ đồ. Việc làm đầu tiên trước khi bạn bắt đầu vẽ sơ đồ mạch nguyên lý là cài đặt các lựa chọn thích hợp cho trang sơ đồ. Từ menu chọn Design > Document Options, hộp thoại Document Options xuất hiện. Chọn kiểu trang sơ đồ trong mục Standard styles Để cài đặt những quy tắc chung được sử dụng cho tất cả các trang sơ đồ Chọn Tools > Schematic Preferences Vẽ sơ đồ mạch nguyên lý. Tìm các thành phần và cài đặt các thư viện thành phần Để quản lý hàng ngàn thành phần DXP tổ chức chúng thành các thư viện theo chủng loại và theo các nhà sản xuất khác nhau. DXP cũng cung cấp công cụ tìm kiếm mạnh để bạn tìm các thành phần. Để tìm kiếm linh kiện cần dùng, chọn Tools > Find Component hoặc click và panel System và chọn Libraries để mở hộp thoại Search Libraries. Trong khung Scope chọn Libraries on Path. Trong trường Path chọn đường dẫn đến thư mục chứa các thư viện thành phần. Trong trường Name của mục Search Criteria nhập *tên linh kiện cần tìm* . Trong đó ký hiệu * được sử dụng để thay thế cho các tiền tố và hậu tố của các nhà sản xuất khác nhau. Click vào Search để bắt đầu tìm kiếm. Tab Results hiển thị quá trình và kết quả tìm kiếm, chọn linh kiện phù hợp trong của sổ Results và ấn Select. Trong trường hợp thư viện chưa được cài đặt thì click và nút Install Libraries và chọn thư viện cần cài đặt. Đặt các thành phần trên sơ đồ mạch và nối dây. Hiển thị panel Libraries, chọn thư viện cần tìm. Sử dụng trình lọc để tìm nhanh các thành phần bằng cách nhập dòng *tên linh kiện cần tìm* vào ô văn bản phía dưới tên thư viện. Một danh sách các thành phần mà tên có chứa tên linh kiện cần tìm được liệt kê trong trường Component Name. Click vào tên linh kiện cần tìm để chọn nó và click vào nút Place. Lúc này con trỏ chuyển thành hình chữ thập mảnh và kéo theo một biểu tưởng thành phần linh kiện, Nhấn phím Tab để mở hộp thoại Component Properties. Trong khung Properties của hộp thoại nhập giá trị cho trường Designator. Tiếp theo chúng ta sẽ kiểm tra mô hình footprint (chân mạch in) của thành phần để chắc chắn đã có một mô hình footprint. Click nút OK để đóng hộp thoại, trái chuột để đặt thành phần lên sơ đồ. Để xoay linh kiện ta chọn linh kiện cần xoay ấn và dữ chuột trái đồng thời ấn nút Spacebar trên bàn phím. Muốn tạo ảnh gương đảo ngược linh kiện ta chọn linh kiện rồi ấn chuột trái chọn Properties, trong mục Graphical chọn Mirrored Để nối dây trong mạch ta vào Place > Wire (phím tắt “ P, W ”) hoặc ấn vào biểu tượng trên thanh Toolbar. Sau khi hoàn thiện xong sơ đồ mạch nguyên lý ta ấn Ctrl + S để nhớ vào hoặc vào File > Save để chuẩn bị chuyển sang thiết kế sô đồ mạch in Làm việc với sơ đồ mạch in (PCB) Trước khi chuyển thiết kế từ trình soạn thảo sơ đồ sang trình soạn thảo mạch in, ta cần phải tạo ra bản mạch in PCB. Cách dễ nhất để tạo bản mạch in PCB trong DXP là sử dụng tiện ính PCB Wizard, nó cho phép ta lựa chọn các khung mạch in theo chuẩn công nghiệp hoặc tự tạo ra mạch in với kích thước tùy trọn . Tạo ra một văn bản PCB mới Chọn PCB Board Wizard trong mục New from Template ở phía dưới của panel File. Nếu lựa chọn này không xuất hiện trên màn hình hãy đóng một vài mục phía trên bằng cách trọn các biểu tượng mũi tên. PCB Board Wizard mở ra. Hình ảnh đầu tiên mà ta nhìn thấy là một trang giới thiệu. Click vào Next để tiếp tục. Trang tiếp là để đặt đơn vị đo là Imperial (đơn vị đo lường của Anh) mils hoặc chọn Metric nếu dùng milimetres Trang thứ ba của tiện ích cho phép bạn lựa chọn khung mạch mà bạn muốn sử dụng. Chọn Custom từ danh sách nếu muốn tự nhập kích thước khung mạch và sau đó ấn Next. Trong trang tiếp theo bạn sẽ nhập các kích thước mạch in. Chọn kiểu Rectangular và nhập kích thước vào các trường Width và Height. Không chọn Title Block and Scale, Legen String, và Dimension Line. Click và nút Next để tiếp tục. Trang thứ năm cho phép ta chọn số lớp trong mạch in (lớp nguồn Power planes ta thường để bằng không), click Next Trang tiếp là để trọn loại Via (xuyên lớp) thường trọn Thruhole vias only Trang thứ bẩy cho phép bạn thiết lập các tùy trọn công nghệ vẽ đường mạch và thành phần. Trong đó Surface-mount Componets là mạch in linh kiện dán. Còn Throgh-hole Components là mạch in linh kiện xuyên lỗ, trong đó phía dưới là mục cho phép ta chọn số đường dây có thể đi qua giữa hai chân linh kiện. Trang cuối cùng cho phép ta thiết lập độ rộng của đường mạch in, kích cỡ chân linh kiện và khoảng cách giữa hai đường mạch in gần nhất Click vào nút Finish để đóng tiện ích lại, bây giờ PCB Wizard đã có tất cả thông tin để tạo ra bản mạch PCB mới. Trình soạn thảo PCB hiển thị một file PCB mới có tên là PCB1.PcbDoc. Văn bản PCB hiển thị với một trang mầu trắng có kích thước mặc định và khung mạch trống (vùng màu đen có lưới). Để tắt trang màu trắng, chọn Design > Board Options và không chọn Display Sheet. Để đổi tên file PCB mới chọn File > Save as. Xác định vị trí trên đĩa cứng mà bạn muốn lưu file PCB, nhập tên file trong trường File Name, click Save. Truyền thiết kế Trước khi truyền thông tin từ sơ đồ sang mạch PCB tróng, đảm bảo rằng tất cả các thư viện liên quan đối với cả mạch sơ dồ và mạch in là có thể sử dụng được Mở mạch sơ đồ chọn Design > Update PC Document. Đế án được biên dịch và hộp hội thoại Engineeing Change Order xuất hiện. Click nút Validate Changes. Nếu tất cả thay đổi là hợp lệ (các đánh dấu màu xanh suất hiện ở cột Status). Click vào Execute Changes để truyền các thay đổi sang PCB. Quá trình kết thúc khi cột done được đánh đấu hết. Click nút Close và mạch PCB xuất hiện cùng với các thành phần sẵn sàng để đặt lên mạch. Nếu không nhìn thấy hết các thành phần thì sử dụng phím tắt V,D để nhìn toàn bộ mạch. Thiết kế mạch in PCB Thiết lập không gian làm việc. Trước khi đặt các thành phần lên mạch, ta cầc thiết lập không gian làm việc như lưới, các lớp và quy tắc thiết kế . Cần đảm bảo lưới đặt được thiết lập đúng trước khi đặt các thành phần. Tất cả các đối tượng đặt trong không gian mạch PCB được sắp xếp trên một lưới gọi là Snap grid. Để thiết lập Snap grid ta chọn Design > Board Options để mở hộp hội thoại Board Options. Trong đó ô Component Grid là để thiết lập bước di chuyển của linh kiện Chọn Design > Board Layers & Colors để mở hộp thoại Board Layers & Colors ở đây ta có thể hiển thị, thêm, loại bỏ, đổi tên và đặt mầu cho các lớp Để thêm các lớp vào mạch in ta có thể chọn Design > Layer Stack Manager vá ấn Add Layer Cài đặt các quy tắc mới. PCB Editor là một môi trường được điều khiển bằng các quy tắc. Điều này có nghĩa là khi ta làm việc trong PCB Editor và thực hiện các thao tác như đặt các đường mạch, di chuyển các thành phần , tự động vễ mạch thì PCB Editor liên tục giám sát từng thao tác để đảm bảo việc thiết kế vẫn tuân theo cá quy tắc đã thiết lập. Nếu có sự vi phạm thì lập tức các lỗi được báo hiệu. Việc cài đặt các quy tắc thiết kế trước khi bạn bắt đầu làm việc với mạch cho phép tránh được các lỗi khi thực hiện. Để thực hiện cài đặt các quy tắc ta chọn Design > Rules, hộp thoại PCB Rules and Constraints Editor xuất hiện. Mỗi loại quy tắc được hiển thị ở panel Design Ruler (phía bên trái) của hộp thoại. Mỗi khi click vào một quy tắc ở panel Design Ruler để chọn nó, bên phải của hộp thoại hiển thị phạm vi mà quy tắc được áp dụng và nhưng điều bắt buộc của quy tắc. Các quy tắc này được mặc định hoặc được cài đặt bởi Board Wizard khi bản mạch PCB mới được tạo ra. Để vẽ mạch một lớp ta cũng có thể chọn Routinglayer trong hộp thoại PCB Rules and Constraints Editor và loại bỏ lớp Top. Đặt các thành phần trên mạch PCB. Bây giờ chúng ta có thể đặt các thành phần theo các vị trí phù hợp của chúng. Nhấn phím tắt V,D để nhìn thấy toàn bộ mạch và các thành phần. Di chuyển con trỏ đến linh kiện cần di chuyển nhấn và dữ chuột trái. Con trỏ chuyển thành hình chữ thập mảnh và nhẩy đến điểm tham chiếu của phần tử. Vừa dữ nút chuột trái vừa di chuyển chuột để kéo thành phần đến điểm đặt theo mong muốn Khi đến vị trí cần thiết, nhả chuột để đặt thành phần. Chú ý rằng các đường nối cũng di chuyển theo thành phần. Sử dụng phím Spacebar trên bàn phím để xoay thành phần trong khi kéo chúng, đồng thời chú ý đến việc tối ưu các đường nối trong khi sắp xếp các thành phần. Vẽ đường mạch in Vẽ mạch là một quá trình xắp xếp các đương mạch và các via trên mạch để nối các thành phần. DXP làm cho việc vẽ mạch trở nên dễ dàng bằng cách cung cấp các công cụ vẽ mạch bằng tay tinh vi. Mặc dù DXP có sẵn các công cụ vẽ mạch tự động rất mạnh, nhưng cũng có một số lý do mà ta nên chọn cách vẽ mạch bằng tay. Đôi khi đó là lựa chọn rất hữu hiệu trong trường hợp vẽ mạch tự động không đáp ứng được yêu cầu mà bạn mong muốn. Trong đa số các trường hợp thì vẽ mạch bằng tay được sử dụng để hiệu chỉnh lại mạch sau khi vẽ tự động. - Vẽ mạch bằng tay Chọn Place > Interactive Routing từ menu (phím tắt P,T) hoặc click nút Con trỏ chuyển thành hình chữ thập mảnh để báo hiệu bạn đang trong chế độ vẽ mạch - Vẽ mạch tự động Từ menu chọn Auto Route > All và chọn Route All. Lúc đó trình vẽ tự động sẽ làm việc và trên màn hình sẽ xuất hiện ô thông báo và quá trình vẽ. Ta có thể qua sát thấy tiến độ vẽ mạch: tổng số đường mạch cần vẽ, số đường mạch đã vẽ và số đường mạch còn lại. Quá trình vẽ mạch thành công khi số đường mạch còn lại bằng 0. Trên cửa sổ của PCB Editor ta cũng quan sát thấy quá trình vẽ mạch rất trực quan. Sau đó ta kiểm tra lại mạch và hiệu chỉnh DXP cũng cho phép vẽ mạch tự động theo vùng tùy chọn. Bằng cách click vào Auto Route > Area và sau đó khoanh vùng cần vẽ tự động Để nâng cao tính chuyên nghiệp khi vẽ mạch ta có thể thêm vào các phần sau. Tạo đường mạch nối với chân linh kiện hình giọt nước để khi hàn không bị bong mạch: Chọn Tool > Teardrops và hộp thoại Teardrops Options xuất hiện, trong mục Teardrop Style chọn Track rồi ấn OK. Đổ đất cho toàn bộ mạch: Chọn Place > Polygon plane từ menu, hộp thoại Polygon plane xuất hiện, vào Connect to Net để chọn Net cần đổ đồng và vào Layer để chọn mặt để đổ đồng, sau đó ấn OK và quét toàn bộ mạch. Để đổ lắc cho các lớp ta chọn Design > Layer Stack Manager, hộp thoại Layer Stack Manager xuất hiện, đánh dấu vào Top Dielectric và Bottom Dielectric, rồi ấn Enter. Sơ đồ nguyên lý (Schematic) vẽ thực tế Sơ đồ mạch in (PCB) vẽ thực tế Mạch sử dụng IC TCA785 điều khiển công suất lớn Thiristor, tải biến áp.

Các file đính kèm theo tài liệu này:

  • docP0150.doc