Giáo trình tin học địa chất hướng dẫn sử dụng MapInfo

Mục lục

- Chương I : Cấu trúc của phần mềm MapInfo và một số khái niệm cơ bản

- Chương II : Tạo mới các Table, Làm việc với Project

- Chương III : Làm việc với các đối tượng hình học trên Mapinfo.

- Chương IV : Làm việc với các đối tượng thuộc tính trên Mapinfo.

- Chương V : Làm việc với Layer Cosmetic.

- Chương VI : Một số sử lý khác.

 

 

doc41 trang | Chia sẻ: maiphuongdc | Ngày: 02/06/2014 | Lượt xem: 14984 | Lượt tải: 43download
Bạn đang xem nội dung tài liệu Giáo trình tin học địa chất hướng dẫn sử dụng MapInfo, để tải tài liệu về máy bạn click vào nút DOWNLOAD ở trên
ớc 1 : Vào Menu [File]-->Chọn SAVE Tables --> Xuất hiện danh sách các Table đã bị sửa đổi cần lưu Hình 9 Bước 2 : Chọn Table hoặc dùng phím Shift or Ctrl để chọn một nhóm các File Sau đó : Chọn nút Save để thực hiện lệnh. 4. Đóng các Table đang được mở. Vào menu [File] --> Chọn Close Table nếu muốn đóng một table hoặc chọn Close All nếu muốn đóng tất cả các Table đang được mở. 5. Làm việc với File WorkSpace File WorkSpace có phần mở rộng là *.WOR là một file kịch bản của MapInfo dạng ASCII ta có thể dùng các phần mềm sọan thảo để thay đổi, sửa chữa. Trong File WorkSpace chứa các thông tin về các Table đang được mở khi tạo ra File đó như : Tên file (đầy đủ đường dẫn nếu nằm ở thư mục khác với file *.wor), bí danh, hiện trạng của màn hình (vị trí, kích cỡ,tỷ lệ zoom ..).... và các lệnh để cho Mapinfo thực hiện. Ví dụ : !Workspace !Version 400 !Charset WindowsLatin1 Open Table "vnmap" As VNMAP Interactive Open Table "color_vn" As COLOR_VN Interactive Set Window Info Position (0.239583,0.864583) Units "in" Width 2.39583 Units "in" Height 3.64583 Units "in" Font ("MS Sans Serif",0,8,0) Open Window Info Map From VNMAP,COLOR_VN Position (0.0520833,0.0520833) Units "in" Width 3.29167 Units "in" Height 2.04167 Units "in" Set Window FrontWindow() ScrollBars Off Autoscroll On Set Map CoordSys Earth Projection 1, 1001 Center (101.0980608,16.52158878) Zoom 3198.42992 Units "km" Preserve Zoom Display Zoom XY Units "degree" Distance Units "km" Area Units "sq km" Set Map Layer 1 Display Graphic Selectable Off Label Line None Position Center Font ("Arial",0,9,0) Pen (1,2,0) With fcode Parallel On Auto Off Overlap Off Duplicates Off Offset 2 Visibility On Layer 2 Display Graphic Selectable Off Label Line None Position Center Font (".VnBlackH",1,12,0) Pen (1,2,0) With TINH_THANHPHO Parallel On Auto On Overlap Off Duplicates On Offset 2 Visibility Zoom (110, 780) Units "km" Object 157 Anchor (105.830895483766,21.138336088167) Object 64 Anchor (105.549182986651,19.918577057342) Object 2 Anchor (103.060009278429,22.146572108219) Set Window Frontwindow() Max ----------------- - Tạo một File WorkSpace : Vào menu [File] ---> Save WorkSpace --> Đặt tên File - Mở một File WorkSpace :Vào menu [File] --->Open WorkSpace-->Chọn File *.wor Chú ý : Khi ta thay đổi vị trí của các File mà file *.wor gọi đến --> Mapinfo sẽ thông báo không tìm thấy File . Do vậy nếu muốn chạy được ta có thể chữa trực tiếp đường dẫn tới Table trong file *.wor Chương III : Làm việc với các đối tượng Đồ họa Các đối tượng trên Mapinfo được lưu giữ thành 2 phần : - Các đối tượng hình học (Object) : Là các đối tượng hiển thị trên bản vẽ như LINE, PLINE, TEXT, REGION, RECTANGULAR,SYMBOL. - Các đối tượng thuộc tính (Attribute): Là giá trị thuộc tính của các đối tượng đồ họa được lưu giữ trong CSDL. I - Một số khái niệm 1- Khái niệm về đối tượng hình học Các đối tượng hình học trong Mapinfo bao gồm - LINE : Là đoạn thẳng có hai đỉnh. - PLINE : Là đường thẳng đi qua n đỉnh ( n >= 2). - ELLIPSE : Là hình Ellipse với 1 tâm và 2 bán kính. Trong trường hợp hai bán kính bằng nhau ta được hình tròn. - SYMBOL : Là ký hiệu được dán vào 1 điểm nào đó của bản vẽ. - REGION : Là Pline khép kín có chứa thuộc tính về vùng - RECTANG : Là hình chữ nhật, hoặc hình vuông - TEXT : Là các đối tượng Text hiển thị trên bản vẽ 2- Khái niệm về thuộc tính hình học Trong mỗi một đối tượng hình học có chứa các thuộc tính hình học. Thuộc tính hình học của đối tượng bao gồm mầu đường bao, mầu nền, loại đường bao, kiểu chữ v..v Mỗi loại đối tượng hình học khác nhau sẽ có một số thuộc tính khác nhau - LINE và PLINE : Có thuộc tính Mầu đường ( Line color ) Loại đường ( Line style) Độ dày đường ( Line with) Độ dài đường (Length) - ELLIPSE, REGION và RECTANG : Ngoài các thuộc tính của đường bao giống Line và Pline còn có thuộc tính về vùng như : Mầu vùng ( Fill color) Kiểu nền (Pattern) Diện tích vùng ( Area square) Chu vi (Primeter) - SYMBOL : Có các thuộc tính Loại Symbol (Symbol Style) Cỡ Symbol (Size) Tọa độ (Coordinate) Màu sắc (Color) -TEXT : Có các thuộc tính Kiểu chữ (Text font) Cỡ chữ (Text Size) Màu sắc (Color) 3- Khái niệm về Layer Cũng như các hệ GIS khác, trên Mapinfo ta có thể mở được nhiều file bản đồ cùng một lúc (*.tab) nhằm phục vụ mục đích chồng ghép các lớp bản đồ khác nhau để có được một bản đồ chuyên đề theo theo yêu cầu của người dùng tin. Đối với GIS việc phân loại và tách các đối tượng trong một hệ cơ sở dữ liệu thành các lớp hay, nói riêng trong Mapinfo là các table (*.tab) là rất cần thiết. Việc phân loại thông tin theo từng lớp như thế nào, nhằm mục đích gì là hoàn toàn phụ thuộc vào yêu cầu của mức độ và quy mô quản lý cũng như các kết quả đưa ra của người dùng. Ví dụ như trên Mapinfo, đối với các bản đồ địa chất ta có thể phân chia thành các lớp đối tượng khác nhau như: - Lớp các bản đồ : Sông, suối - Lớp các bản đồ : Giao thông (đương bộ, đường sắt,đường mòn..) - Lớp các bản đồ : Địa giới, Địa danh - Lớp các bản đồ : Đường đồng mức - Lớp các bản đồ : Ranh giới địa chất - Lớp các bản đồ : Tuổi, kí hiệu địa chất ................ Với việc phân chia thành các lớp dựa trên cơ sở phân loại nào đó giúp cho việc quản lý chặt chẽ hơn, cũng như tạo điều kiện thuận tiện trong việc sửa chữa và cập nhật về sau. Trên Mapinfo, mỗi Table được mở sẽ được gọi là một Lớp (Layer) trong một cửa sổ (Window). Layer trong Mapinfo có tên trùng với tên file *.tab mà bạn mở. Trường hợp đặc biệt khi bạn mở cùng một file nhiều lần thì sau mỗi lần mở Mapinfo sẽ tự động thêm các số hiệu lần mở vào sau tên Layer của bạn. Ngoài các Layer do người dùng mở trong Mapinfo còn có một Layer đặc biệt có tên “Layer Cosmetic” sẽ được nói đến trong chương V. Để xem các Layer đã được mở trong một cửa sổ, hoặc thay đổi thứ tự, thuộc tính thể hiện trên màn hình của một Layer nào đó ta thực hiện các bước sau : Bước 1 : Vào menu [Map] --> chọn Layer Control Bước 2 : Thực hiện các thay đổi cần thiết (xem hình 10) Hình 10 Trong đó : - Lựa chọn Visiable : Có hiện Layer được chọn hay không - Lựa chọn Editable : Cho phép thêm mới, sửa chữa các đối tượng trên Layer được đánh dấu. Chú ý : Tại một thời điểm Mapinfo chỉ cho phép đặt một Layer ở chế độ Editable. - Lựa chọn Selectable : Cho phép chọn các đối tượng trên Layer hiện thời hay không. - Lựa chọn Label : Hiện thị nhãn (Label) của các đối tượng trong Layer được chọn - Nút Add : Thêm một Layer (một Table đã được mở) vào cửa sổ hiện thời. - Nút Remove : Loại bỏ không hiển thi Layer được chỉ định ra khỏi của sổ hiện thời nhưng chưa đóng Table đó. - Nút Up/Down : Dịch chuyển Layer được chọn lên trên/xuống dưới để xắp xếp thứ tự xuất hiện trên màn hình của các Layer. - Nút Display : Thay đổi cách thể hiện trên màn hình của các Layer như giới hạn phạm vi hiển thị trên màn hình(Zoom Max/Zoom Min) ... - Nút Label : Tạo nhãn cho các đối tượng của Layer được chọn theo một trường mà người dùng chỉ định - Nút Thematic : Thay đổi cách hiển thị các bản đồ chủ đề được tạo ra do lệnh: Creat Thematic Map. II. TạO MớI các đối tượng Đồ HọA Để thuận tiện cho người dùng Mapinfo cũng đưa ra hai hộp công cụ là : Main và Drawing (Xem Hình 11) Hình 11 1a. Tạo mới một đối tượng Text Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ EditAble) Bước 2 : Vào Menu [Options] --> chọn Text Style Khai báo : Kiểu chữ (Font), Cỡ chữ (Size), Màu sắc ... nếu cần Bước 3 : Chọn biểu tượng Text ( A ) trong hộp công cụ Drawing Bước 4 : Chọn vị trí con trỏ (điểm bắt đầu của Text) Bước 5 : Nhập giá trị của Text, để kết thúc nhấn phím trái chuột hoặc tắt nút tạo Text mới ( A ) trong hộp công cụ Drawing 1b. Thay đổi thuộc tính của một đối tượng Text Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ EditAble) Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa Hoặc lựa chọn đối tượng cần sửa --> Vào menu [Edit] --> Get info ----> Cho ta hình 12 Hình 12 Tại hộp đối thoại này, ta có thể thay đổi nội dung, kiểu, góc quay... của text 2a. Tạo mới 1 đối tượng Symbol: Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ EditAble) Bước 2 : Vào Menu [Options] --> chọn Symbol Style Khai báo : Kiểu Symbol, Cỡ Symbol (Size), Màu sắc ... nếu cần Bước 3 : Chọn biểu tượng Symbol trong hộp công cụ Drawing Bước 4 : Chọn vị trí con trỏ đặt Symbol, để kết thúc tắt nút tạo Symbol 2b. Thay đổi thuộc tính của một đối tượng Symbol Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ EditAble) Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa Hoặc lựa chọn đối tượng cần sửa --> Vào menu [Edit] --> Get info ----> Cho ta hình 13 Hình 13 Tại đây, ta có thể thay đổi Kiểu của Symbol hoặc tọa độ ... 3a. Tạo mới 1 đối tượng Line: Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ EditAble) Bước 2 : Vào Menu [Options]--> chọn Line Style Khai báo : Kiểu đường , Màu sắc, độ rộng ... nếu cần Hình 14 Bước 3 : Chọn biểu tượng Line trong hộp công cụ Drawing Bước 4 : Chọn vị trí điểm đầu của Line (Nhấn phím trái, giữ nguyên), kéo tới vị trí điểm cuối của Line ---> Thả phím trái 3b. Thay đổi thuộc tính của một đối tượng Line Bước 1 : Vào menu Map --> chọn Layer Control (Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ EditAble) Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa Hoặc lựa chọn đối tượng cần sửa --> Vào menu Edit --> Get info ----> Cho ta hình 15 Hình 15 4. Tạo mới 1 đối tượng Vùng (Region, Circle, Ellip, Rectangular): Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ EditAble) Bước 2 : Vào Menu [Options] --> chọn Region Style Khai báo : Kiểu nền (Pattern), màu nền, Kiểu đường biên, Màu đường biên, độ rộng ... nếu cần Hình 16 Bước 3 : Chọn biểu tượng Region(Circle, Rectangular...) trong hộp công cụ Drawing Bước 4 : - Nếu vẽ Region : Bấm phím chuột trái tại những điểm cần vẽ, để kết thúc nhấn đúp phím trái chuột tại điểm cuối cùng - Nếu vẽ đường tròn hoặc Ellip : Nhấn phím trái chuột tại vị trí xác định tâm (giữ nguyên kéo tới vị trí xác định) thả chuột - Nếu vẽ hình vuông, hình chữ nhật : Nhấn phìm trái chuột tại vị trí một góc --> giữ nguyên, kéo tới góc đối diện --> thả chuột Chú ý : Ngoài các chức năng nêu trên đối với các đối tượng dạng Line, Pline, Region còn cho phép ta thực hiện các chức năng : . Edit Vetex : Cho phép ta di chuyển từng Vetex của đối tượng. Khi đã chọn chức năng Edit Vetex trong hộp công cụ Drawing thì chỉ có thể di chuyển được từng Vetex chứ không thể di chuyển ( Move) được cả đối tượng, muốn huỷ bỏ chế độ Edit Vetex ta chọn lại vào chức năng đó 1 lần nữa. . Insert Vetex : Cho phép chèn thêm Vetex vào đối tượng. Muốn chèn thêm Vetex vào một đối tượng thì buộc phải kích hoạt các Vetex của đối tượng, sau đó chọn chức năng Insert Vetex trong hộp công cụ Drawing. 5. Chọn một nhóm các đối tượng trên Mapinfo - Nhấn phím Shift trong khi chọn từng đối tượng - Chọn tất cả các đối tượng trong một hình chữ nhật (Marquee Select) - Chọn tất cả các đối tượng nằm trong 1 Region (Boundary Select) - Chọn tất cả các đối tượng nằm trong 1 Hình tròn (Radius Select) Khi một nhóm hay một đối tượng được chọn Mapinfo sẽ đưa vào một Table tạm thời có tên là Selection hoặc các Query . Khi ta đóng các Layer hoặc thoát khỏi Mapinfo thì các Query và Selection sẽ tự động được xoá Chú ý : Trên Mapinfo không những cho phép ta thay đổi thuộc tính của 1 đối tượng mà còn cho phép ta thay đổi thuộc tính của cả một nhóm đối tượng được chọn. III- sửa chữa các đối tượng Đồ họa Ngoài việc thay đổi các thuộc tính hình học của các đối tượng, trong Mapinfo còn cho phép một số phép xử lý phức hợp khác với đối tượng hình học. Cụ thể là : - Sao chép 1 đối tượng (Copy) - Di chuyển 1 đối tượng (Move) - Chia 1 đối tượng thành nhiều đối tượng (Split) - Tạo một đối tượng phức hợp từ nhiều đối tượng (Combine) - Xoá phần đối tượng này bị đối tượng khác đè lên (Erase, Erase Outside) - Chèn Vetex vào các vị trí giao nhau (Ovelay Note) - Biến đổi các đối tượng từ loại này thành loại khác (Convert) 1. Sao chép đối tượng ( Copy) Các bước thực hiện Bước 1 : Chọn đối tượng cần sao chép (hoặc 1 nhóm đối tượng) Bước 2 : Vào Menu Bar [Edit] --> chọn Copy. Bước 3 : Vào menu [Map] ---> Layer Control đặt Layer cần dán các đối tượng sao chép ở chế độ Editable Bước 4 : Vào Menu Bar [Edit] ---> Chọn Paste để dán Sau khi thực hiện lệnh sao chép ta được các đối tượng mới nằm trùng vị trí với đối tượng cũ với dữ liệu thuộc tính (Attribute) không thay đổi khi hai Layer có cấu trúc CSDL giống nhau. 2. Di chuyển đối tượng ( Move) Muốn di chuyển đối tượng việc đầu tiên phải kích hoạt Layer chứa chúng ( đặt Layer ở chế độ Editable) sau đó đánh dấu đối tượng và dùng phím chuột trái(nhấn và giữ nguyên) để di chuyển, kết thúc thả chuột trái. 3. Chia 1 đối tượng thành nhiều đối tượng (Split) Chức năng này chỉ có thể áp dụng với các đối tượng là Line, Pline, Ellipse, Region Các bước thực hiện : Bước 1 : Muốn thực hiện chức năng này đầu tiên ta phải xác định được các vị trí cần chia. Sau đó tạo 1 vùng (Region) đi qua các điểm đó ( gọi là vùng A). Bước 2 : Đặt Layer chứa các đối tượng cần chia ở chế độ EditAble Bước 3 : Đánh dấu các đối tượng cần chia Bước 4 : Vào Menu Bar [Objects] ---> Chọn Set Target (Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp) Bước 5 : Chọn “vùng A” vừa vẽ (được coi như là chuẩn) Vào Menu Bar [Objects] ---> Chọn Split để chia đối tượng Sau các thao tác trên về mặt hình học đối tượng sẽ bi chia thành 1 số đối tượng nhỏ hơn tuỳ thuộc vào số giao điểm của “vùng A” với đối tượng. Bước 6 : Khai báo giá trị thuộc tính (xem hình 17) --> Chọn OK để thực hiện Hình 17 Đối với giá trị thuộc tính tuỳ lựa chọn “Disaggreation Method” mà ta sẽ thu được các giá trị khác nhau như chọn : () Blank : Khi trường nào được chọn với lựa chọn Blank thì giá trị thuộc tính của đối tượng thu được sẽ Bằng 0 (= 0) nếu đó là trường số Bằng rỗng (= ‘ ‘ ) nếu đó là trường ký tự ( ) Value : Giá trị thuộc tính của các đối tượng mới thu được sẽ giống như của đối tượng ban đầu. ( ) Area Propotion : Lựa chọn này chỉ có tác dụng với các trường là trường số và đối tượng được chia là đối tượng vùng. Sau phép chia này các giá trị mới tạo ra sẽ được xác định lại dựa vào tỷ số giữa diện tích các vùng được chia và giá trị của đối tượng đầu. Việc chia 1 đối tượng thành nhiều đối tượng mới có khá nhiều tác dụng. Một ví dụ đơn giản: Nếu bạn có 1 đường Đứt Gãy liên tục mà qua mỗi vùng địa chất nó lại có 1 Line Style khác nhau muốn giải quyết nó thì bạn phải chia đối tượng đó thành những đối tượng bé hơn bằng lệnh Split sau đó thay đổi các đối tượng mới cho phù hợp với yêu cầu. 4. Cộng nhiều đối tượng thành 1 đối tượng mới (Combine) Ta có thể cộng nhiều đối tượng thành một đối tượng nhờ lệnh Combine. nhưng có một số chú ý sau : - Lệnh Combine chỉ làm việc với các đối tượng là Line, Pline, Region. - Khi thực hiện lệnh cộng (Combine) thì chỉ có các đối tượng cùng kiểu mới có thể cộng được với nhau. Ví dụ như ta có thể cộng các đối tượng là Pline với nhau chứ không thể cộng Pline với Region. Các bước thực hiện : Bước 1 : Đánh dấu các đối tượng cần Combine Bước 2 : Vào Menu Bar [Objects] ---> Chọn Combine Bước 3 : Khai báo giá trị thuộc tính (xem hình 18) Hình 18 Có 4 tuỳ chọn trong mục “Aggregate Method” Trong 4 tuỳ chọn này thì 2 tuỳ chọn và chỉ áp dụng với trường số. Mỗi tuỳ chọn trên có ảnh hưởng đến giá trị thuộc tính của đối tượng mới như sau : - No Change : Nếu 1 trường được xác định là “No Change” thì sẽ nhận giá trị là giá trị của của đối tượng được chọn làm Set Target. - Value : Cho phép nhập giá trị cho đối tượng mới sẽ tạo ra - Sum : Đối tượng mới tạo ra có giá trị bằng tổng các giá trị của các đối tượng ban đầu (chỉ áp dụng với trường số). - Avegare : Đối tượng mới tạo ra có giá trị bằng giá trị trung bình cộng của các đối tượng ban đầu (chỉ áp dụng với trường số). Với lệnh Combine đối tượng mới tạo ra sẽ có thuộc tính hình học (loại đường, mầu sắc ..v.v ) của đối tượng được chọn làm Set Target. 5. Xoá phần trùng nhau của các đối tượng ( Erase) - Lệnh Erase chỉ làm việc với các đối tượng là Line, Pline, Region. Mục đích : Tạo ra các Polygon đảo để thuận tiện trong việc tô màu, xác định chính xác diện tích của một vùng thì bắt buộc ta phải xoá phần diện tích bị chèn và đè của các vùng khác lên nó. Các bước thực hiện : Bước 1 : Đặt Layer chứa các đối tượng cần xóa ở chế độ Editable Bước 2 : Đánh dấu các đối tượng cần xóa một phần Bước 3 : Vào Menu Bar [Objects] ---> Chọn Set Target (Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp) Bước 4 : Chọn các đối tượng dạng vùng có phần chung với "Target" cần xóa Vào Menu Bar [Objects] ---> Chọn Erase Bước 5 : Khai báo giá trị thuộc tính (xem hình 17) --> Chọn OK để thực hiện 6. Xóa các đối tượng nằm ngoài một vùng (Erase Outside) - Lệnh Erase Outside chỉ làm việc với các đối tượng là Line, Pline, Region. Các bước thực hiện : Bước 1 : Đặt Layer chứa các đối tượng cần xóa ở chế độ Editable Bước 2 : Đánh dấu các đối tượng cần xóa một phần Bước 3 : Vào Menu Bar [Objects] ---> Chọn Set Target (Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp) Bước 4 : Chọn các đối tượng dạng vùng có phần chung với "Target" cần xóa Vào Menu Bar [Objects] ---> Chọn Erase OutSide Bước 5 : Khai báo giá trị thuộc tính (xem hình 17) --> Chọn OK để thực hiện 7. Chèn Vetex vào các vị trí giao nhau (Ovelay Note) - Lệnh Ovelay Note chỉ làm việc với các đối tượng là Line, Pline, Region. - Thực hiện nó sẽ chèn Vetex vào các vị trí giao nhau của các đối tượng. Các bước thực hiện : Bước 1 : Đặt Layer chứa các đối tượng cần chèn Vetex ở chế độ Editable Bước 2 : Đánh dấu các đối tượng cần chèn Vetex Bước 3 : Vào Menu Bar [Objects] ---> Chọn Set Target (Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp) Bước 4 : Đánh dấu đối tượng thứ 2 có giao điểm hay phần chung với "Target" Bước 5 : Vào Menu [Object] ---> chọn Ovelay Note Sau khi thực hiện xong chức năng này đối tượng đầu của bạn ( đối tượng chọn làm Set Targe) sẽ được chèn thêm 1 Vetex vào mỗi điểm giao ứng dụng : Nếu như bạn muốn vẽ 1 đối tượng mới bắt đầu tại vị trí giao nhau của 2 đối tượng cho trước, vì chế độ bắt điểm (Snap) của Mapinfo chỉ bắt được vào các đỉnh Vetex. Hãy thực hiện chức năng Ovelay Note để chèn thêm Vetex vào điểm giao nhau đó và bắt đầu quá trình vẽ của bạn. 8. Biến đổi các đối tượng từ loại này thành loại khác (Convert) Trong Mapinfo cho phép biến đổi giữa 2 kiểu đối tượng là Pline Region Chức năng này khá quan trọng trong khi bạn muốn Edit các đối tượng, sẽ được nói kỹ hơn trong phần thực hành. Các bước thực hiện Bước 1 : Đặt Layer chứa các đối tượng cần thay đổi ở chế độ Editable Bước 2 : Chọn đối tượng (hoặc một nhóm các đối tượng) cần thay đổi Bước 3 : Vào Menu [Object] ---> chọn Convert to ... - Convert to Region : Biến đổi từ Pline thành Region - Convert to Polyline : Biến đổi từ Region thành Pline Trên đây là 1 số thao tác cơ bản khi sử lý với các đối tượng hình học của 1 bản vẽ. Sau đây ta sẽ thao tác với các đối tượng thuộc tính của chúng. Chương IV: Làm việc với các đối tượng thuộc tính (Attribute) trên Mapinfo Trong Mapinfo thuộc tính của bản vẽ được lưu trữ bằng dạng bảng (Table) trong đó có các trường (Field) và các bản ghi (Record). Mỗi bản ghi sẽ lưu trữ các giá trị thuộc tính của 1 đối tượng hình học. Làm việc với thuộc tính (Attribute) trên Mapinfo có những thao tác sau: - Thay đổi cấu trúc của 1 Table (Modify Structure) - Sửa đổi dữ liệu của 1 Table (Update Column) - Chèn thêm dữ liệu vào 1 Table ( Append Rows To Table). - Lựa chọn dữ liệu của 1 Table ( Select SQL). I. Thay đổi cấu trúc 1 Table ( Modify Structure) Muốn thay đổi cấu trúc 1 Table làm như sau vào : Menu Bar [Table] ---> [Maintenance] ---> Table Structure . Thay đổi cấu trúc 1 Table cho phép : - Chèn thêm 1 trường bằng tuỳ chọn Add Field. - Huỷ bỏ 1 trường bằng cách di vệt sáng về trường đó sau đó chọn Remove Field. - Thay đổi (tên trường, kiểu dữ liệu) của 1 trường bằng cách di vệt sáng về trường đó --> đặt lại tên, chọn lại kiểu dữ liệu trong bảng chọn. Sau khi thao tác xong ấn table sẽ nhận cấu trúc mới đã thay đổi. II. Sửa đổi dữ liệu của 1 Table ( Update Column) Có 3 cách sửa đổi dữ liệu từ 1 Table : - Sửa từ cửa sổ Brows - Sửa từ bảng cửa sổ Info Tool. - Sửa bằng chức năng Update Column. 1- Sửa từ cửa sổ Brows Muốn sửa chữa dữ liệu từ cửa sổ Brows ta vào : Menu bar [Window] ---> [New Brower Window] để mở cửa sổ Browse với Table muốn sửa chữa. Đánh dấu 1 bản ghi sau đó, nếu bạn muốn tìm đối tượng chứa bản ghi đó vào[ Menu Bar\ Query\ Find Selection]. Sau đó sửa chữa ngay trên cửa sổ Brows. 2- Sửa từ bảng cửa sổ Info Tool. Vào hộp công cụ Main chọn chức năng Infomation ( chữ I ) --> Nhấn chuột trái trên đối tượng cần xem ---> Các thông tin thuộc tính sẽ xuất hiện trên cửa sổ Infomation, có thể tiến hành sửa chữa trực tiếp trên đó . Mọi sửa chữa của bạn sẽ được ghi lại thành thuộc tính của đối tượng. 3- Sửa bằng chức năng Update Column. Vào Menu [Table] ----> Update Column Chức năng Update Column cho phép bạn cập nhật dữ liệu của một trương theo một trường khác của cùng Table hay theo các trường của Table khác cùng mở. Ta chia làm 2 phần : - Update Column theo các trường của bản thân nó. - Update Column theo các trường của các Table khác cùng mở. a- Update Column theo các trường của bản thân nó. Chức năng này cho phép thay đổi giá trị của 1 trường dựa vào giá trị 1 trường khác có những tuỳ chọn sau (Hình 19): Hình 19 - Table To Update : Lựa chọn tên Table muốn cập nhật. - Column To Update : Lựa chọn trường (Field) muốn cập nhật. - Value : Cho phép lựa chọn giá trị trường đó theo các trường khác. Giá trị mới này có thể xác định bằng biểu thức trường hoặc các hàm khác trong Mapinfo. Ví dụ : Bạn có 1 Table tên là A, trong Table A có 2 trường [ ID(char), DES(char)]. Muốn thay đổi trường ID với giá trị tương ứng bằng ID + DES làm như sau : - Table To Update : A - Column To Update : ID - Value : ID + DES Sau các thao tác này bạn sẽ được kết quả theo ý muốn. b- Update Column theo các trường của các Table khác cùng mở. Khi bạn mở đồng thời nhiều Table thì có thể sửa chữa dữ liệu của mình theo các Table khác. Các thao tác này như sau - Table To Update : Lựa chọn tên Table muốn cập nhật (Gọi là Table 1) - Column To Update : Lựa chọn Trường ( Field) cần cập nhật. - Get Value From Table : Lựa chọn tên Table lấy giá trị (Gọi là Table 2) - Join : Khi Update Column từ 1 Table khác buộc bạn phải có điều kiện cộng. Mapinfo cho phép có 2 điều kiện cộng chuẩn - Where Matche : Tức là lấy giá trị tương thích theo thứ tự hàng (RowId) - Where Objects With From -Is Within Objects From -Contain Objects From -Intersects Objects From Điều kiện cộng thứ 2 sẽ xác định tương quan của các đối tượng hình học trong với các đối tượng hình học thuộc . Điều kiện cộng là đúng với từng tuỳ chọn nếu : Is Within - Đối tượng thuộc nằm hoàn toàn trong đối tượng Contain - Khi đối tượng thuộc bao hàm đối tượng của Intersects- Khi đối tưọng của 2 Table giao nhau -Caculate : Xác định giá trị lấy theo phương thức nào . Value : Lấy theo giá trị. . Avg : Lấy theo giá trị trung bình ( chỉ áp dụng với trưòng số) . v..v.. - Of : Xác định xem giá trị lấy theo trường nào hoặc lấy theo biểu thức của trường nào ( Expresion). Chú ý khi kiểu dữ liệu của 2 trường không tương thích thì kết quả sẽ là 0- với trường số và bằng trống với trường kí tự. 4. Thêm dữ liệu vào một Table ( Append Rows To Table). Có nhiều cách để chèn thêm dữ liệu vào 1 Table. Trong đó có 3 cách chính như sau - Vẽ 1 đối tượng mới. - Copy 1 đối tượng từ 1 Table khác - Chọn chức năng Append Rows To Table a. Vẽ 1 đối tượng mới. Khi vẽ 1 đối tượng mới Mapinfo tự động chèn thêm một bản ghi trẵng vào CSDL chứa nó Record này không có giá trị, muốn gán giá trị bạn có thể làm theo thao tác ở phần 2 b. Copy 1 đối tượng từ 1 Table khác Khi Copy đối tượng từ Table này (gọi là Table 1) sang Table khác ( gọi là Table 2) Mapinfo tự động chèn thêm vào Table được ghi 1 số Record tương ứng với số đối tượng được Copy. Nếu theo thứ tự từ t

Các file đính kèm theo tài liệu này:

  • docbai_giang_mapinfo_5839.doc
Tài liệu liên quan