Phân tích thiết kế hệ thống thông tin quản lý sinh viên

 CHƯƠNG I: Phương pháp luận phân tích thiết kế hệ thống thông tin quản lý sinh viên

 I.Khái quát về hệ thống qun lý sinh viên

 II.Các giai đoạn phân tích thiết kế hệ thống thông tin

 Chưng iI : Giới thiệu về VisualFoxPro

 CHƯƠNG III : Phân tích ,thiết kế và xây dựng hệ thống quản lý sinh viên

 I.Phân tích hệ thống quản lý sinh viên

 II.Thiết kế hệ thống quản lý sinh viên

 III.Thiết kế giao diện và xây dựng chưng trình

 Chương IV : Cài đặt đánh giá và hướng phát triển

 1. Cài đặt

 2. Đánh giá kết quả thực hiện

 3. Phương hướng phát triển

 4. Lời cảm ơn.

 

doc57 trang | Chia sẻ: huong.duong | Ngày: 14/09/2015 | Lượt xem: 970 | Lượt tải: 4download
Bạn đang xem trước 20 trang tài liệu Phân tích thiết kế hệ thống thông tin quản lý sinh viên, để xem tài liệu hoàn chỉnh bạn click vào nút DOWNLOAD ở trên
g ta cũng thêm những tính năng nâng cao kinh nghiệm phát triển ứng dụng và thêm những tiện lợi hơn cho ứng dụng. . Các lớp nền của Visual foxpro làm dàng hơn khi thêm gần 100 đặc tính vào ứng dụng. . Component gallery tạo sự dễ dàng khi quản lý các lớp của Visual Foxpro, những văn bản, những tệp tin mà bạn muốn thêm vào ứng dụng của mình. . Phần mới application Builder cho phép thêm một cơ sở dữ liệu, tạo, thêm hay chỉnh sửa các bảng dữ liệu, các report, form, dịch và chạy những ứng dụng cho đúng cách. *Cải tiến công cụ debug Trong version này của Visual Foxpro, bạn có thể tìm lỗi và kiểm tra những thành phần của ứng dụng mọtt cách dễ dàng hơn, bạn có chức năng mở công cụ debug trong cửa sổ chính của Visual Foxpro nơi chúng hiện hữu cùng màn hình giao diện ứng dụng của bạn. Chương trình debug cung cấp những công cụ để bật những điểm dừng kiểm tra những tình huống và code gần giống như thể hiện trong môi trường bẫy lỗi của Visual C. Trong cửa sổ watch và local trình bày cách cài đặt thuộc tính, những đối tượng và giá trị những thành phần của mảng. Để xem giá trị của biến hiện thời, bạn chỉ việc đặt con trỏ vào tên biến trong cửa sổ trace. Cửa sổ output cho bạn xem một cách tiện lợi những yêu cầu thông tin được mã hoá và kết quả xuất hiện trực tiếp trên một góc của cửa sổ từ cửa sổ ứng dụng. Trong version này của Visual foxpro cũng gồm có một bản nâng cấp của profiler application để bạn có thể dùng để phân tích những chương trình, những ứng dụng hay các đề án để mã hoá cho thi hành. Bản thân động cơ coverage profiler là có thể tuỳ chọn giao diện trên visual foxpro. Dễ dàng khi thiết kế bảng và lập từ điển dữ liệu mở rộng. Trong version này của table designer, dễ dàng thêm các index giống như tạo các field và chỉ rõ nhiều giá trị mặc nhiên làm cho khi thiết kế form nhanh hơn. Có thể định nghĩa một khoá thường trên cùng một trang và trên cùng một hàng với field. Trang table cho bạn truy xuất trực tiếp vào validation rule, trigger và statistic cấp bảng. Lớp và thuộc tính của thư viện mặc định kiểu điều khiển của một field: khi thêm một field vào form, bạn tạo một điều khiển mà bạn muốn chỉ bằng một buớc dễ dàng. Hơn nữa, thuộc tính input mark và format giúp bạn định kiểu hiện diện của dữ liệu. Connection designer làm việc với trình quản trị cơ sở dữ liệu ODBC tạo những kết nối dễ dàng hơn cho việc tạo lập. Nhà thiết kế cũng cung cấp thêm những thuộc tính cho sự kết nối. Nâng cao tính năng query và view designer. Có thể tạo outer joint, chỉ định tên gọi cho các cột hoặc chọn một số record thoả mãn điều kiện nào đó.. bằng query và view designer. Dùng view designer cho phép xác định những thuộc tính giốmg nhau trên field hữu của bảng. Gia tăng những tính năng cho form và sự dễ dàng trong thiết kế. Theo những nâng cấp từ điển dự trữ dữ liệu trợ giúp trong thiết kế form, sử dụng form designer sẽ dễ dành và tiên lợi hơn. Form designer hỗ trợ công cụ single document interface(SDI) và Multiple document interface(MDI) cho bạn làm những gì mình muốn trên ứng dụng. Sử dụng SDI, tạo được những cửa sổ ứng dụng bên trong cửa sổ desktop của window. Shortcut Menu designer giúp tạo những shortcut sử dụng trong hành vi Right click. Form và những điều khiển có thêm những thuộc tính này và phương thức mới cho việc điều chỉnh từng phần của form. Trong cửa sổ properties, bạn có thể chọn một nhóm các điều khiển, thấy những thuộc tính chung, chung đổi chúng. Nếu cần sử dụng một khaỏng rộng để quan sát hay chỉnh sửa những thuộc tính này, bạn dùng properties zoom. Công cụ alignment canh những đối tượng theo hàng hay theo cột, di chuyển chỗ này, chỗ kia rất dễ dàng. Một yêu cầu chung của những nhà phát triển hệ thống là có thể sử dụng phím trong cửa sổ properties và cho phép di chuyển từ đối tượng này sang đối tượng khác bằng cách nhấn những tổ hợp phím CTRL kết hợp với các phím: PAGEUP, PAGEDOWN, HOME, END. Nếu muốn thay đổi những gì trong khi thi hành, nút design trên toolbar cho bạn truy xuất trở lại thiết kế màn hình nhanh. Công cụ soạn thảo viết code dễ dàng hơn khi định dạng các chương trình, thay đổi màu sắc, nâng cao chức năng tìm và thay thế. Cung cấp khả năng truy xuất bằng shortcut hay các phím tắt như bấm mouse phải để bật những hành vi cho bất kì đối tượng nào. Trong chương này gồm có: *Bắt đầu Visual Foxpro *Giới thiệu về Project manager *Giới thiệu các kiểu thiết kế Visual Foxpro *Thiết kế các kiểu cơ sở dữ liệu Bắt đầu Visual Foxpro Double-click vào biểu tượng Microsoft Visual Foxpro: Khi khởi động Visual Foxpro, Project Manager tạo một Project mới và trống, vì thế bạn có thể thêm những mục hiện có hoặc tạo những mục mới vào Project này. Sử dụng Project manager, bạn có thể làm quen với visual foxpro một cách nhanh chóng. Project manager cung cấp một phương pháp đơn giản, dễ thấy để tổ chức và làm việc với các Table, Form, Database, Report, Query và các file khác khi bạn đang sắp xếp các bảng và cơ sở dữ kiệu hay đang tạo một ứng dụng. Giới thiệu về project Manager Project Manager giúp tổ chức dữ liệu, lập query hay thiết kế các ứng dụng hoàn hảo. Chỉ bằng một vài thao tác chuột, bạn có thể giữ lại duy trì các bảng, các query và các tổ chức các mối quan hệ giữa các form, report, label, code, bitmap và các file khác. Giao diện của Project Manager giống như giao diện của windows exployer. Các đường kẻ cho thấy một hệ thống có đẳng cấp giữa các item trong Project Manager. Bạn có thể mở ra hay thu lại các chi tiết để thấy các cấp tổ chức. 3. Làm việc với bảng dữ liệu Bảng dữ liệu lưu trữ của bạn theo dòng, cột giống như bảng tính. Mỗi dòng tượng trưng cho một record, mỗi cột tượng trưng cho field của record đó. Có thể thiết kế hai loại bảng dữ liệu trong Visual Foxpro : Database table: bảng dữ không tuỳ thuộcvào bất cứ cơ sở dữ liệu nào. Free table: bảng dữ liệu đống vai trò thành phần trong cơ sở dữ liệu Thiết kế cơ sở dữ liệu bao gồm tạo các cơ sở dữ liệu (Table), xác định các Field cần thiết có trong bảng dữ liệu, các mối quan hệ cần có trong ứng dụng. Trong khi thiết kế các bảng dữ liệu bạn phải làm một số công việc chi tiết như: chọn dữ liệu, tạo tiêu đề diễn giải, xác định các giá trị mặc nhiên cho từng trường, cũng như chọn khoá, tạo bẫy lỗi (Trigger) và tạo chỉ mục cho bảng dữ liệu. Đăc biệt phải thiết lập các mối quan hệ giữa các bảng dữ liệu với nhau. 3.1-Tạo bảng dữ liệu Trong Visual Foxpro, một bảng dữ liệu có thể tồn tại ở một trong hai trạng thái nằm trong một cơ sở dữ liệu nào đó hoặc là một bảng dữ liệu tự do. Việc một bảng không nằm trong một cơ sở dữ liệu nào đó sẽ có lợi điểm so với bảng dữ liệu tự do, những lợi điểm bao gồm: Có thể tạo Field tên dài. Có thể tạo những tiêu để và những lời chú giải cho từng field. Có thể tạo giá trị mặc nhiên, mẫu nhập dữ liệu cho từng trường. Có thể tạo những quy tắc ở mức trường và record Có thể tạo khoá chính cũng như mối liên kết toàn vẹn giữa các bảng dữ liệu. Những thủ tục kiểm tra việc chèn , cập nhật hoặc xoá trong bảng dữ liệu. 3.1.1 Tạo bảng Bạn có thể tạo bảng dữ liệu bằng hai cách : Cách 1: trong Project Manager chon mục Database/Table, rồi chọn nút New. Cách 2: sử dụng câu lệnh Create Table Cú Pháp :CREATE TABLE [] [Null | not Null ] Primary Key [Tên Trường] Tag [Tên tag] 3.1.2-Tên Field Khi thiết lập cac Field trong bảng ta phải xác định tên Field, kiểu dữ liệu, độ dài. Ngoài ra còn phải xác định Field đó cho phép giá trị Null, có giá trị Default, cần có quy tắc kiểm tra dữ liệu hay không. Trong Visual Foxpro mỗi bảng cho phép tối đa 255 Field. Đối với bảng dữ liệu tự do, tên Field dài tối đa 10 kí tự. Đối với bảng nằm trong cơ sở dữ liêu thì tên trường cho phép dài tối đa 128 kí tự. Đặt tên field trong bảng dữ liệu có thể thực hiện theo hai cách sau : Trong công cụ Table Designer, gõ tên Field vào hộp Name Hoặc dùng lệnh Create Table hoặc Alter Table 3.1.3- Chọn loại dữ liệu Trong khi tạo Field trong bảng dữ liệu, ta phải chọn kiểu dữ liệu cho từng Filed đó. Để chọn được loại dữ liệu phù hợp với từng Field phải xem xét các trường hợp sau : Các giá trị lưu trữ thuộc loại dữ liệu nào. Các giá trị lưu trữ trong trường cần chiều dài tối đa bao nhiêu Các phép toán nào có thể sử dụng trên vùng dữ liệu này Visual Foxpro có thể tạo chỉ mục hay sắp xếp các giá trị trong field này không. Để chọn dữ liệu cho từng Field, trong Table Designe, kích vào hộp có mũi tên chỉ xuống trong hộp thoại Type. Ngoài ra ta còn có thể xác định kiểu dữ liệu trong câu lệnh Create. 3.1.4- Giá trị Null Khi một trường có thể chứa giá trị Null, nghĩa là giá trị ở Field này có lúc có, có lúc không. Để xác định đây là Field có giá trị Null, trong Table Designer, kích vào cột Null ở Field đó. Việc hiện diện giá trị Null sẽ gây ra một tác động lớn trong bảng cơ sở dữ liệu. 3.1.5-.Diễn giải cho Field Sau khi xác định được các mục cơ bản của Field như tên, kiểu dữ liệu, độ dài...ta có thể thêm phần diễn giải cho rõ ràng hơn và thuận lưọi hơn cho việc cập nhật và bảo trì sau này. 3.1.6-Tên bảng dữ liệu Nếu dùng câu lệnh Create Table hay công cụ Database Designer, thì phải xác định trong câu lệnh Visual foxpro sẽ tạo một bảng mới và lưu trên đĩa. Tên bảng bao gồn các kí tự , kí số, dấu gạch dưới nhưng phải bắt đầu bằng một ký tự hay dấu gạch dưới. Nếu bảng nằm trong một cơ sở dữ liệu thì phải xác định tên bảng dài. Tên bảng dài cho phép tối đa 128 ký tự, tên bảng xuất hiện trong công cụ Project Designer, Database Designer, View Disgner cũng như xuất hiện trên thanh tiêu đề của cửa sổ Browse. Ghi chú : tên bảng không phải là tên File Trang Field gồm các mục : Names: là vùng đặt tên các field trong cơ sở dữ liệu. Type: chọn kiểu dữ liệu cho từng trường. Width: chiều dài của từng trường. Decimal : Số số lẻ (nếu trường có kiểu dừ liệu số) Index: Field này có tạo chỉ mục hay không(chọn bằng cách đánh dấu X vào mục này.) Null: vùng này cho phép giá trị Null hay không, nếu có thì đánh dấu X vào mục này. 4. Các quy tắc kiểm tra dữ liệu Quá trình kiểm tra xem dữ liệu nhập có phù hợp với kiểu dữ liệu điều kiện hay giới hạn nào đó ở mức Field hay ở mức Record được gọi chung là “quy tắc kiểm tra dữ liệu có hiệu lực”. Các quy tắc kiểm tra này chỉ tồn tại trong bảng dữ liệu. Có 3 loại quy tắc kiểm tra :quy tắc kiểm tra ở mức trường, quy tắc kiểm tra ở mức record, quy tắc kiểm tra ở mức bảng. Kết quả mà bạn nhập vào sẽ được kiểm tra bằng biểu thức mà bạn định nghĩa. Nếu giá trị nhập vào không đúng quy tắc kiểm tra thì giá trị đó sẽ bị loại bỏ. 4.1- Quy tắc kiểm tra dữ liệu nhập vào trong trưòng, có thể kiểm tra tính hợp lệ của dữ liệu thông qua quy tắc kiểm tra dữ liệu được cài đặt ở mức Field. Trong Table Designer, gõ quy tắc kiểm tra trong hộp Field Validation. Hoặc dùng lệnh Check trong câu lệnh Create Table. Hoặc dùng mệnh đề Set trong câu lệnh Alter Table Để tạo quy tắc kiểm tra ở mức Field ta thực hiện ở các bước sau : Mở bảng dữ liệu trong Table Designer. Chọn Field cần thiết lập quy tắc. Chọn nút bên cạnh hộp Rule. Trong hộp thoại Expresstion Builder, thiết lập các quy tẳc rồi chọn OK. Trong hộp Message, gõ nội dung cânf thông báo khi quy tắc này sai. Chọn nút Ok 4.2- Quy tắc kiểm tra dữ liệu ở mức Record dùng để kiểm tra dữ liệu khi người dùng đưa dữ liệu vào. Quy tắc kiểm tra này khác với kiểm tra ở mức Field ở chỗ: khi ta muốn kiểm tra dữ lỉệu của một Field nhưng nó phụ thuộc vào một hay nhiều giá trị khác của trường khác Để tạo quy tắc kiểm tra dữliệu ở mức Record và câu thông báo lỗi thực hiện như sau: Trong công cụ Table Designer, gõ quy tắc kiểm tra và câu thông báo lỗi vào phần Rule và Message. Hoặc dùng mệnh đề Check trong câu lệnh Create Table, hay Alter Table. 4.3 Quy tắc kiểm tra ở mức bảng. Khi muốn hai hay nhiều trường được Field sẽ được so sánh, kiểm tra...trước khi record đó được đưa vào bảng dữ liệu, bạn có thể thiết lập quy tắc cho bảng. Cách thực hiện như sau: Chọn bảng dữ liệu cần thực hiện rồi chọn nút Modify. Trong Table Designer, chọn trang Table. Trong hộp Rule, gõ biểu thức cần kiểm tra. Trong hộp thoại Message box, gõ thông báo mà bạn muốn xuất hiện khi quy tắc kiểm tra sai. Chọn nút Ok. Trong Table Designer, chọn nút Ok. 4.4- Các câu lệnh liên quan đến tạo và chỉnh sửa bảng dữ liệu. Lệnh Create Table. Chức năng: tạo bảng dữ liệu Cú Pháp :CREATE TABLE [] [Null | not Null ] Primary Key [Tên Trường] Tag [Tên tag] Lệnh Alter Table Chức năng : dùng để thay đổi cấu trúc của bảng dữ liệu đã được tạo lập. Cú Pháp : ALTER TABLE Tablename1 ALTER [colume] Fieldname2 [Null | Not Null ] [ SET DEFAULT Expression2] [SET CHECK expression2 [error massage text2]] [DROP DEFAULT] [DROP CHECK] [NOVALIDATE] 5. Làm việc với Record 5.1- Xác định thư mục làm việc Thông thường khi khởi động Visual Foxpro, thư mục làm việc là ...\Vfp98. nếu dữ liệu của bạn lưu trữ ở thư mục khác khi làm việc sẽ gây bất tiện. Để khắc phục điều này ta sử dụng lệnh SET DEFAULT TO Chức năng: thiết lập thư mục và ổ đĩa mặc nhiên Cú pháp : SET DEFAULT TO [PATH] 5.2 - Hiện nội dung của bảng. Cách nhanh nhất để hiện nội dung của bảng dữ liệu là hiện nội dung của chúng trong cửa sổ Browse. Cửa sổ Browse hiện nội dung của các dòng các cột, bạn có thể sử dụng thanh cuốn để xem. Cách thực hiện: Từ Menu File, chọn Open rồi chọn bảng dữ liệu cần xem. Từ Menu View chọn thư mục Browse Bạn cũng có thể chọn bảng dữ liệu trong Project Manager rồi chọn nút Browse. 5.3 - Di chuyển trong bảng dữ liệu. Dùng thanh cuốn để di chuyển bảng dữ liệu và thể hiện thông tin từ các Field khác, bạn cũng có thể sử dụng các phím mũi tên và phím Tab để di chuyển. Ngoài ra cũng có thể sử dụng Menu lệnh để thực hiện công việc này. Trong Menu Table, chọn mục Go To Record. Trong bước tiếp theo, chọn một trong các công cụ Top, Bottom, Next, Previous hoặc Record. Nêú chọn mục Record, bạn phải gõ vào số Record cần xem rồi chọn Goto. 5.4 -Thêm một Record mới vào bảng dữ liệu Cách1: bạn có thể thêm một bản ghi mới vào bảng dưc liệu nhanh nhất bằng cách đặt cửa sổ Browse hay Edit ở chế độ Append. Cách2: Sử dụng lệnh Insert của SQL, lệnh này dùng để nhập dữ liệu từ một mảng hay các biến vào trong bảng dữ liệu. Cách3: sử dụng lệnh Append Blank kết hợp với lệnh Replace Cú Pháp: APPEND BLANK Chức năng: Thêm một Record trắng vào cuối bảng dữ liệu hiện hành. sau khi thực hiện lệnh này, muốn nhập dữ liệu vào bạn phải dùng lệnh Replace hay Gather. Thêm dữ liệu từ bảng khác Bạn có thể thêm dữ liệu vào một bảng khác bằng cách sử dụng lệnh APPEND FROM. Cú pháp: APPEND FROM FieldName1? [FIELD fieldList] [FOR lExpresion] 5.6-Xoá Record Bạn có thể xoá record bằng cách đánh dấu xoá chúng ra khỏi bảng dữ liệu. Khi các Record bị đánh dấu xoá, bạn có thể khôi phục lại được, còn khi đã xoá khỏi bảng dữ liệu thì không xoá lại được. 5.7-Khôi phục lại các Record đã bị đánh dấu xoá Bạn có thể khôi phục lại các Record bị đánh dấu xoá bằng các cách sau đây: Làm lại thao tác như đánh dấu xoá cho những Record nào muốn khôi phục Trong Menu Table, chọn Recall Records. Dùng lệnh Recall ở cửa sổ lệnh. 5.8-Xoá các Record đã đánh dấu xoá ra khỏi bảng dữ liệu Sau khi đánh dấu xoá các Record, bạn có thể xoá chúng ra khỏi bảng dữ liệu bằng các cách sau: Trong cửa sổ Browse, chọn thư mục Browse Delete Record trong menu Table. Dùng lệnh PACK khi sử dụng lệnh này bảng dữ liệu phải được mở ở chế độ độc lập. 5.9-Xoá tất cả các Record trong bảng dư liệu Bạn có thẻ xoá tất các Record trong bảng dữ liệu mà không cần đánh dấu xoá trước bằng lệnh ZAP. Khi đó tất cả các bản ghi không thể khôi phục lại được. 6-Sắp xếp dữ liệu sử dụng Index Một khi ta tạo được bảng dữ liệu, ta có thể sắp xếp dữ liệu bằng cách sử dụng Index để tăng tốc độ trích xuất dữ liệu. Bạn có thể sử dụng Index để làm tăng độ tìm kiếm dữ liệu cũng như kết xuất in ấn. Index rất quan trọng trong việc tạo mối quan hệ giữa các bảng cơ sở dữ liệu. Index trong Visual Foxpro giống như bảng mục lục của cuốn sách. Mỗi mục lục cuốn sách nằm trên một trang nào đó được xác định qua số trang, cũng như một Record nằm trên một bảng dữ liệu đều có một chỉ số riêng biệt nằm trong file Index. Khi muốn truy xuất đến một Record nào đó, Visual Foxpro sẽ dựa vào chỉ số này để đến Record đó. 6.1-Tạo Index Một khi có bảng dữ liệu, bạn có thể tạo một Index trên Field hay một biểu thức. Để dùng Index có hiệu qủa, tạo Index trên những Field thường hay dùng để đọc dữ liệu trong bảng, trong Query hay trong Report. Nếu tạo Index trên những Field không sử dụng thường xuyên ví dụ như Field địa chỉ thì nó sẽ làm chậm quá trình xử lý. Ngoài ra còn có thể tạo Index trên nhiều Field bằng cách kết hợp chúng lại trong một biểu thức. Trong Project Manager, chọn bảng dữ liệu muốn tạo Index rồi chọn nút Modify. Trong công cụ Table Designer, chọn trang Index màn hình sau sẽ xuất hiện. Trong hộp thoại Name, gõ tên Tag bạn cần tạo. Trong hộp Type chọn laọi Index. Bạn có thể chọnh một trong 4 loại: + Primary + Candidate + Regular Index + Unique Trong hộp Expression gõ tên Field bạn cần Index hoặc nhấn nút bên cạnh để xây dựng một biểu thức Index. Hộp Filter dùng để lọc các Record thảo mãn một điều kiện nào đó trước khi tiến hành Index. Chọn nút Ok. 6.2- Truy xuất dữ liệu với Index Sau khi đã tạo index cho các trường khác nhau trong bảng dữ liệu, có thể truy xuất dữ liệu hay hiện dữ liệu trong bảng theo nhiều đang sắp xếp khác nhau. Sử dụng một trong 2 cách sau để thay đổi dạng Index. Dùng menu lệnh: Trong Project Manager, chọn bảng dữ liệu đã tạo index. Chọn nút browse Trong menu Table, chọn mục Properties. Trong hộp Index chọn loại Index cần dùng. Chọn Ok. 7. Mối quan hệ giữa các bảng dữ liệu Database Deigsner dễ dàng tạo mối quan hệ giữa các bảng dữ liệu bằng cách nối các chỉ mục lại với nhau. Quan hệ được tạo trong Database Deigsner được gọi là Persistent Relationship. Mỗi lần sử dụng các bảng trong công cụ query hay View Designer hoặc trong Data Environment khi tạo Form thì các mối quan hệ này sẽ xuất hiện. 8. Forms Bạn có thể dùng Form cung cấp cho người dùng giao diện để hiện và nhập thông tin vào cơ sở dữ liệu, Form còn cung cấp một tập hợp các đối tượng để đáp ứng lại những thao tác của người dùng trên Form giúp họ có thể hoàn thành công việc dễ dàng. 8.1- Tạo Form mới bằng form Designer Trong mục Project Designer chọn mục form trong document rồi chọn nút new. Hoặc trong menu file chọn mục New, chọn form rồi chọn nút New file. Hoặc gõ lệnh Create Form trong cửa sổ lệnh. 8.2- Các đối tượng (Control) Textbox là ô văn bản dùng để nhập giá trị dạng văn bản Label thường dùng để thể hiện các hướng dẫn trên form Command button đây là một đối tượng dùng để thực hiện một tác vụ nào đó khi người dùng kích chuột vào hoặc ấn phím Enter. Command button group quản lý một tập hợp các Command button. Listbox là danh sách hiện sẵn các giái trị mà người dùng có thể chọn Combobox là đối tượng có thể chứa nhiều một danh sách để chọn. Check box là ô cho phép chọn có thể chọn đồng thời nhiều ô. Option button chỉ cho phép chọn 1 trong các trường hợp Grid đây là bảng lưới Active X(OLE) là một đối tượng dùng để nhúng, kết hợp với các đối tượng khác. 8.3- Các thuộc tính của các control Mỗi loại control trên Form đều có các thuộc tình đi kèm các thuộc tính này mô tả đầy đủ các thuộc tính đi kèm. Trong cửa sổ properties ngoài thuộc tính của control nó còn thể hiện các phương thức của đối tượng đó. Mỗi một control có nhiều thuộc tính trong đó có các thuộc tính sẵn có người dùng không thể phát triển, có những thuộc tính người dùng có thể phát triển theo ý của mình. Sự phát triển có thể được thực hiện khi thiết kế form hoặc được thực hiện khi chạy chương trình. Mỗi loại đối tượng đều có những thuộc tính khác nhau, chú ý thuộc tính hình thức như Font, Fontsize, name, caption, height, width. 8.3- Các Method Method là một phương thức xử lý của control. Nó thường là các đoạn chương trình viết cho các mã khác nhau. Event là các sự kiện xảy ra đối với control. Click là bấm chuột để làm gì. Double click : nhấn kép chuột để làm gì Lostfocus : mất con trỏ thì làm gì Gostfocus : nhận được con trỏ thì làm gì Init : sự khởi đầu Keypress : ấn phím thì làm gì Load: xảy ra trước sự kiện Init Destroy : huỷ bỏ Mousemove : di chuột qua Reports Trong các ứng dụng của fox thường có phần chức năng là nhập dữ liệu vào cho cơ sở dữ liệu và lấy cơ sở dữ liệu ra phục vụ cho người có nhu cầu nhập tin. Để đưa dữ liệu vào ta nhập từ form. Để lấy dữ liệu ra ta lấy bằng report 1. Loại báo cáo Báo cáo chi tiết, chủ yếu mang tính liệt kê thể hiện các bản ghi trong tệp cơ sở dữ liệu một cách tuần tự. Báo cáo tổng hợp, tổng hợp dữ liệu trong tệp trước khi đưa ra báo cáo, việc tập hợp có thể theo một hay nhiều tiêu thức khác nhau. 2. Tạo báo cáo nhanh. Nó hỗ trợ cho việc tạo báo cáo nhanh đơn giản. Visual Foxpro sẽ giúp cho tạo ra đối tượng trên báo cáo sau đó ta có thể thiết kế lại b1. Mở tệp cơ sở dữ liệu muốn lấy dữ liệu ra b2. Create Report b3. Chọn Quick Report b4. Chọn trường trong tệp cơ sở dữ liệu, sau đó ấn Ok Sử dụng Report Designer C1: Vào File ->New ->Report C2: Trong Project chọn Report sau đó chọn newfile C3: +Create Report +Modify Report Thành phần của Report Header : phần đầu của Report Title : dùng để đặt tiêu đề cho Report Detail : phần chứa các trường của Report Sumery : phần tổng kết Report footer 5. Sử dụng các control : Trên thanh công cụ Toolbar có những thuộc tính để chèn vào Report A: nhằm tạo nhãn cố định Ab : dùng để thể hiện lấy thông tin từ tệp cơ sở dữ liệu hoặc bộ nhớ. 10. Menu Menu cung cấp một phương thức có cấu trúc và giao diện với người dùng để tác động lên những câu lệnh trong ứng dụng của bạn. Việc sáp xếp thích hợp và thiết kế Menu có hệ thống sẽ giúp cho ngưới dùng được thuận tiện khi sử dụng ứng dụng của bạn. 10.1- Sử dụng menu trong ứng dụng Thông thường người ta hay xem menu trước khi sử dụng. Nếu menu của bạn thiết kế tốt, người dùng sẽ nắm vững hệ thống của bạn. Với công cụ Menu Designer của Visual Foxpro, bạn có thể tạo ra menu làm tăng hiệu quả trong ứng dụng của bạn. Trong mỗi phần của Visual foxpro đều có những menu hệ thống riêng biệt. Phần dưới đây trình bày cách tạo menu hệ thống. Các bước tạo menu hệ thống Việc tạo menu hệ thống phải qua một số bước sau đây: Sắp xếp và thiết kế : quyết định menu nào bạn cần, chúng xuất hiện ở đâu trên màn hình, cần tạo những menu con nào. Tạo menu và submenu : sử dụng công cụ Menu Designer để tạo các đề mục chính, các mục nằm trong menu và submenu. Gắn các câu lệnh để thực hiện các tác vụ bạn muốn. Biên dịch Menu. Tiến hành chạy thử và kiểm tra Tổ chức menu hệ thống Sự tiện ích của hệ thống này tuỳ thuộc vào chất lượng của menu hệ thống. Nếu bạn đầu tư thời gian vào thiết kế menu, thì người dùng sẽ dễ dàng và nhanh chóng biết cách sử dụng. Tổ chức menu theo những công việc mà người dùng sẽ làm, không tổ chức theo thứ tự những chương trình theo ứng dụng của bạn. Người dùng có thể hình dung mô hình ứng dung của bạn tổ chức như thế nào bằng cách xem xét menu và các submenu. Việc thiết kế menu và submenu ấn tượng sẽ giúp cho người sử dụng hiểu được phong cách để hoàn thành công việc họ phải làm như thế nào. Tạo tiêu đề cho mỗi menu một cách có ý nghĩa Tổ chức các mục trong menu theo những yêu cầu thường hay sử dụng, theo trình tự logic hay theo thứ tự Alphabete. Nếu bạn không đoán được trình tự của công việc cũng như tính logic thì bạn sắp xếp các mục trong menu theo thứ tự Alphabet. Việc sắp xếp các menu theo trình tự này sẽ hữu ích khi số lượng các mục trong menu lớn hơn 8, nếu có nhiều mục như vậy, người dùng sẽ tốn nhiều thời gian để tìm kiếm một mục nào đó, việc sắp xếp các mục theo trật tự Alphabet sẽ giúp cho người dùng tìm kiếm nhanh hơn. Đặt các đường kẻ ngang phân cách các nhóm trong mục menu. Giới hạn số lượng các mục trong menu để hiện diện trên màn hình. nếu số lượng vượt quá chiều dài màn hình thì tạo submenu. Tạo menu Bạn có thể tạo menu bằng cách điều chỉnh lại menu hệ thống trong Visual Foxpro hoặc bằng cách tạo menu riêng cho mình, bạn có thể dùng công cụ quick menu để tạo menu hệ thống như sau: Trong Project Manager, chọn trang other, sau đó chọn mục Menu và nút New. Chọn thư mục menu . Màn hình Menu Designer xuất hiện. Trong Menu chọn mục Quick menu. Màn hình Menu Designer sẽ chứa các thông tin về Menu chính của Visual Foxpro. Chỉnh sửa các menu của hệ thống bằng cách thêm hay chỉnh sửa chúng. Sau khi tạo xong Menu, cần phải biên dịch chúng. Tạo các mục trong menu Sau khi tạo xong menu, bạn có thể đặt các mục trong các menu. Các mục này có thể mô tả câu lệnh của Visual Foxpro hoặc các thủ tục mà bạn muốn người dùng thi hành, hoặc các mục menu có thể chứa các submenu khác. Để thêm các mục trong menu bạn thực hiện như sau: Trong cột Prompt, chọn menu nào bạn muốn thêm các mục trong đó. Trong hộp Result chon submenu. Một nút Create sẽ xuất hiện bên cạnh danh sách. Chọn nút Create, một cửa sổ mới sẽ xuất hiện, bạn có thể gõ các mục của menu trong đó. Tạo Submenu Mỗi một Menu bạn đều có thể tạo cá

Các file đính kèm theo tài liệu này:

  • docP0171.doc